WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Max file upload definitive answer needed (2 posts)

  1. David Leeming
    Member
    Posted 3 years ago #

    I have looked through various forum postings but still can't crack this one. Any help appreciated!

    I have installed WP latest version on Ubuntu 10 with latest LAMP installed using apt-get, ona local machine. This server runs on a local network. All works fine. But I need to increase the file upload size. I tried all of the below in vain, it doggedly retains 2M maximum.
    - Looked for php.ini (using locate... it did not exist, only php.ini-production and -development in the /usr/share/php5 folder)
    - Therefore, coped /usr/share/php5/php.ini-production to create php.ini in same folder, and then
    - Changed the variables max file size and max post size to 64M
    - Still no effect, it says 2M max (after restart)

    - Tried adding to /var/www/wordpress/wp-config.php
    define(‘WP_MEMORY_LIMIT’, ‘64M’);
    - Still no effect

    - Added same line to wp-settings.php
    - Still no effect

    - Created a php.ini file with the exact code below and saved it in
    /var/www/wordpress
    AND
    /var/www/wordpress/wp-admin
    - still no effect

    [PHP]
    post_max_size 64M
    upload_max_filesize = 64M

  2. David Leeming
    Member
    Posted 3 years ago #

    The php.ini file in /etc/php5/apache2 is the one to edit, change those two variables and save and restart, and it works!

Topic Closed

This topic has been closed to new replies.

About this Topic