WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] MAX CPU Usage (70 posts)

  1. Roundbox
    Member
    Posted 1 year ago #

    With the latest All-in-one-event-calendar, our CPU usage has been maxed out and we are getting limited by the host. I have gone through the usual shut off all plugins to isolate the issue and it is due to AI1. Anyone have any suggestions or experiencing the same issue?
    http://www.hubsportscenter.org hosted at GreenGeeks

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. luminus18
    Member
    Posted 1 year ago #

    I am having the same problem. What version of AI1 are you using?

    I have no idea how to resolve this, and am thinking about changing plugins. Is that a good idea?

  3. faithengineer
    Member
    Posted 1 year ago #

    I am having the same issue as well. I'm looking for another program, this plugin is maxing out my resource usage with my host and I have very low traffic on the site.

  4. Roundbox
    Member
    Posted 1 year ago #

    We have Version 1.9.5 installed. We have put WP SuperCache on the site with no change on resource usage. I am still seeing 80-100% cpu usage constantly and am working continuously with the host to not shut down the site. The main feature of the site is promoting events. We only get about 75 visitors a day to the site so it is not a high-traffic site.

  5. shanafourde
    Member
    Posted 1 year ago #

    I am having the same problem. I have had to deactivate the plugin because of this.

    Too bad, because I really like the features of All-in-One Event Calendar.

  6. geoffreysf
    Member
    Posted 1 year ago #

    I'm having this problem too.

  7. wellcaffeinated
    Member
    Posted 1 year ago #

    Same issue here too...
    I think it may have to do with one of the cron jobs that AI1 has injected into wp_cron.
    ai1ec_cron [] 2013/04/10 17:27:08 (21 hours 22 minutes) 86400 (1 day)

  8. shanafourde
    Member
    Posted 1 year ago #

    There is some info on the Time.ly website.
    http://help.time.ly/customer/portal/questions/785582-robots-attacking-calendar-non-stop

    The relevant info is:

    the canonical url’s being applied by your SEO plugin should fix the problem. This bit of code in your head:
    <link rel="canonical" href="http://misportonline.com/calendar/">

    is supposed to tell google that anything with a URL based on that (ex. http://misportonline.com/calendar/action:agenda/) should not be indexed.

    Can everyone confirm that your SEO plugin is adding the link rel in your head? AND confirm that you are still getting the other pages (like /calendar/action:agenda/) indexed?

    2.0 will release with the canonical url link rel tag added if you are not running an SEO plugin. 2.0 is coming out at the beginning April. We are confirming that this will fix the problem for you.

    If anyone else has insights on this issue we would appreciate it!

    I haven't tested this yet. If anyone tries it, please let me know if it works or not.

    Thanks!

  9. malkieh
    Member
    Posted 1 year ago #

    I have not had major issues with server load in the past, although All-in-One Event Calendar is slow and does use a lot of server resources.

    The latest version is hopeless I will have to take the site down as it (All-in-One Event Calendar) is killing the calendar site and other sites on the same server.

  10. ntemple
    Member
    Posted 1 year ago #

    Same problem here. I have two sites using All-In-One Event Calendar and they taking down the server with CPU usage and out-of-memory errors

    I'll take a look at the spider usage pattern as well, I hadn't thought of that.

    It's even worse with the Hostgator VPS, because when the max memory is allocated, the system just kills the Apache process, killing _all_ sites on the server.

    Can we expect a resolution to the resource issues soon?

  11. malkieh
    Member
    Posted 1 year ago #

    I have support tickets raised with Timely regarding this and other issues. I received a response that did not in any way answer my issue, in fact I do not think the ticket was even read. I have now raised another support ticket.

    Regarding a possible spider usage issue, I do not think this is the problem I have as the site was working OK then went very slow as soon as I updated. I think this is another example of poor programming by Timely and rushing out updates before they are tested.

  12. valpreston@familyeguide.com
    Member
    Posted 1 year ago #

    I'm having the same problem.

    Has anyone tried the previous suggestion with success...

    the canonical url’s being applied by your SEO plugin should fix the problem. This bit of code in your head:
    <link rel="canonical" href="http://misportonline.com/calendar/">

    is supposed to tell google that anything with a URL based on that (ex. http://misportonline.com/calendar/action:agenda/) should not be indexed.

  13. ntemple
    Member
    Posted 1 year ago #

    Yes, tried that, and it helps a little in that fewer pages are being indexed by search engines (is that really a good thing?!), so fewer requests to the server.

    The underlying problem, however, isn't the number of pages being indexed ("good" bots like google generally are pretty good about not pounding servers).

    The core problem is that with the most recent updates, each page is taking way too much memory and CPU to generate individually.

  14. geoffreysf
    Member
    Posted 1 year ago #

    Anyone savvy enough to make the plug-in not load on pages that aren't calendar/event pages?

  15. judetheobscure
    Member
    Posted 1 year ago #

    I'm having the same problem too. CPU maxing out.
    Also inability of other plug-ins which help with improving page load speed to work with ai1ec.

  16. nicola.peluchetti
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    does the spike in cpu resources happen when the calendar is viewed and does this slow down the rendering of the calendar page?
    If so, in the file class-ai1ec-calendar-controller.php ( located in the folder app/controller ) replace the function

    public function get_view_args_for_view( Ai1ec_Abstract_Query $request ) {

    with content of this pastebin http://pastebin.com/xyUyB6Ng remembering to include

    private $cache_exact_date = array();
            private $cache_time_limit = array();

    before the function. This fixed an issue for a pro user which reported really slow loading times, but it has not been throughly tested yet, so keep a backup of the old function in case of problems

  17. bravenewniche
    Member
    Posted 1 year ago #

    Had a client site shut down by Hostgator this week for no apparent reason (no spike in visitors, no resource hog plugins that I knew of), and then I read this thread.

    We've got AI1EC on that site, so I ran the Debug Bar and found that a page using a calendar shortcode to display a category was using 74 queries out of 162 on the page. WooCommerce was the second biggest hog on the page, because of two widget we're running in the sidebar.

    We've implemented caching on the site so hopefully this relieves the resource usage...

    Had been using Events Calendar for a long time, but lately was recommending AI1EC to clients. Will go and run a query test on the site with EC and see what we get.

  18. malkieh
    Member
    Posted 1 year ago #

    bravenewniche I hope your caching solution works for your site, however, I found All-in-One Event Calendar would not work with caching plugins such as Wp-super-cache and W3-total-cache.

  19. nicola.peluchetti
    Member
    Plugin Author

    Posted 1 year ago #

    @bravenewniche can you please tell me exactly which queries are run?

  20. bravenewniche
    Member
    Posted 1 year ago #

    malkieh - I'm running Quick Cache on that site; so far no glitches, though I'm not running the minify yet on the JS/CSS

    nicola - Here are three illustrative queries for category colours, and none of the events on the resulting page even use any of these category colours... I can get you the complete list of 162 queries if you'd like.

    SELECT term_color FROM wp_ai1ec_event_category_colors WHERE term_id = 102
        require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/responsive/page.php'), the_content, apply_filters('the_content'), call_user_func_array, do_shortcode, preg_replace_callback, do_shortcode_tag, call_user_func, Ai1ec_Events_Helper->shortcode, Ai1ec_Events_Helper->_get_view_and_restore_globals, Ai1ec_Calendar_Controller->get_calendar_page, Ai1ec_Calendar_Helper->get_html_for_categories, Ai1ec_Events_Helper->get_category_color_square, Ai1ec_Events_Helper->get_category_color #133 (0.1ms)
        SELECT term_color FROM wp_ai1ec_event_category_colors WHERE term_id = 95
        require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/responsive/page.php'), the_content, apply_filters('the_content'), call_user_func_array, do_shortcode, preg_replace_callback, do_shortcode_tag, call_user_func, Ai1ec_Events_Helper->shortcode, Ai1ec_Events_Helper->_get_view_and_restore_globals, Ai1ec_Calendar_Controller->get_calendar_page, Ai1ec_Calendar_Helper->get_html_for_categories, Ai1ec_Events_Helper->get_category_color_square, Ai1ec_Events_Helper->get_category_color #134 (0.1ms)
        SELECT term_color FROM wp_ai1ec_event_category_colors WHERE term_id = 103
        require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/responsive/page.php'), the_content, apply_filters('the_content'), call_user_func_array, do_shortcode, preg_replace_callback, do_shortcode_tag, call_user_func, Ai1ec_Events_Helper->shortcode, Ai1ec_Events_Helper->_get_view_and_restore_globals, Ai1ec_Calendar_Controller->get_calendar_page, Ai1ec_Calendar_Helper->get_html_for_categories, Ai1ec_Events_Helper->get_category_color_square, Ai1ec_Events_Helper->get_category_color #135 (0.1ms)
  21. malkieh
    Member
    Posted 1 year ago #

    bravenewniche thanks for mentioning Quick Cache. I am trying it on a site with a All-in-One Event Calendar install.

  22. nicola.peluchetti
    Member
    Plugin Author

    Posted 1 year ago #

    @bravenewniche if you can send me the complete log i'd be grateful. maybe just copy it on pastebin.

    @malkieh keep us informed on your experience with Quick Cache.

  23. bravenewniche
    Member
    Posted 1 year ago #

    nicola - here's the full results of the query output

    http://pastebin.com/ErKUkaMQ

  24. bravenewniche
    Member
    Posted 1 year ago #

    So far Quick Cache has kept things quiet on 1 of my A1EC sites.

    BTW, thought I'd share this from some stats on that same site - this just seems like a crazy waste of font-loading...

    http://seehowtwo.com/a1ec.png

    Until the plugin authors fix some of these issues - it's such a great plugin on the front end! - as geoffreysf said, the trick is to figure out how to keep all this from loading EXCEPT on events pages... off to the drawing board!

  25. nicola.peluchetti
    Member
    Plugin Author

    Posted 1 year ago #

    Fonts should be cached by the browser, anyway they are loaded from javascript and in the next (1.11) version we will limit loading of javascript only to the pages which contain the calendar, the widget or the single event page.

  26. mjhale
    Member
    Posted 1 year ago #

    We've been experiencing the same issue on a few sites where this plugin is installed. I don't believe the issue is related to the client-side loading of files. After a couple of hours of running the server reaches full CPU usage. Here is one of the common errors we're seeing in our error log: http://pastebin.com/ry7yDdCE. Here's also some slow queries that were logged: http://pastebin.com/dRi1ZBCX.

  27. nicola.peluchetti
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    the Uncaught exception 'Ai1ec_Event_Not_Found' error should be related to a bug in PHP. Usually you went to the "Add new event" page and it was blank. This should be solved in 1.10 standard.
    One other cause for High CPU usage is bot crawling. Search bots crawl calendar pages indefinitely as all the url are valid and this is known to cause problem. You must disallow crawling on sub calendar pages.
    As for the query, it's slow, but it's 0.001442 and it's a simple select on a table with no JOIN so it might be slow due to some other reasons, like the high cpu usage

  28. mjhale
    Member
    Posted 1 year ago #

    The websites are all running 1.10-standard. I haven't heard from anyone that the "Add new event" page was blank when it was being used. We also haven't gotten any reports of seeing any issues from the error, but it was just something we saw in the logs.

    That sounds like a reasonable explanation for the slow queries, thanks.

    We'll go ahead and try to disable crawling for calendar pages and we'll report back.

    Also, here is our stack in case it helps you or anyone else: Ubuntu 12.04.2 LTS, Apache 2.2.22, MySQL 5.5.31, PHP 5.3.10, Varnish 3.0.3.

  29. dynamon
    Member
    Posted 1 year ago #

    We have been having a similar issue since 31 May on our site. CPU usage has been 100% and physical and virtual memory usage are all time high before the plugin was deactivated. The number of occurrences of the line showing Out of memory error associated with ai1ec files on 31 May is 10523. Here is the error log. Hope it helps.
    http://goo.gl/7b14x

  30. shanafourde
    Member
    Posted 1 year ago #

    Have you all followed the directions here and created a robots.txt file?

    http://support.time.ly/limiting-excessive-google-crawls/

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic