WordPress.org

Ready to get started?Download WordPress

Forums

Polylang
[resolved] Masthead section not translated anymore (4 posts)

  1. janpeeters
    Member
    Posted 1 year ago #

    Hi,

    I use a masthead section on my websites homepage to welcome visitors with some larger text. With Polylang 0.9.8 this section nicely translated from one to the other language. In other words, I could enter text in Dutch on the Dutch homepage and in English on the English homepage. Now the masthead text is synchronised between the two homepages.
    I've seen that you're trying to implement as much synchronisation as possible for features and images etc. which is great, but with sections this is not handy.
    Hopefully you've got a idea how I can get the old behaviour back. I'm using Pagelines Framework 2.4.

    Thanks, Jan
    http://www.janpeeters.nl

    http://wordpress.org/extend/plugins/polylang/

  2. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Jan. I am sorry that your site is broken again with the ne w polylang version. I don't know how the masthead of Pagelines works. I believe I found where you can define it. But how did you translate it?

  3. janpeeters
    Member
    Posted 1 year ago #

    Hi,

    I've found the culprit. I had synchronisation of 'custom fields' in Polylang settings activated. Therefore it also synchronised the text between languages (which seemingly uses custom fields). By deactivating it and entering the translated text again everything got solved.
    Not sure if not synchronising 'custom fileds' will bring me into trouble om some other part of WordPress, but for now everything is back to normal.
    Thanks for your quick response. The added features for version 1 are really great.

    Jan

  4. Chouby
    Member
    Plugin Author

    Posted 1 year ago #

    Great! The Synchronization feature (for whatever) is just an help to avoid repetitive actions, but it is not suitable for everybody. So you should not loose anything else that (if you use custom fields), you will have to type them in all your posts and translations (as with previous versions of Polylang)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic