WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Masthead link (7 posts)

  1. waynertrain
    Member
    Posted 8 years ago #

    I am using the red train template and would like to make the masthead a link to my home page. Does anyone know how to do it?

    I know that I have to attach a link to the masthead pic, but I don't know where to do it at. Thanks in advance for your help.

  2. ebusiness
    Member
    Posted 8 years ago #

    Look in the theme editor (and you will see the php files that control the template.

    You probably have one called header.php - this will be the one to edit and insert the link ... if you are comfortable editing php files.

  3. waynertrain
    Member
    Posted 8 years ago #

    the red train template doesn't have a header.php file so I'm stuck doing it in the style sheet or the index.php file. Any help would be greatly appreciated.

  4. LiverpoolLad
    Member
    Posted 8 years ago #

    You need to look for a specific header div, like below

    `<div id="header">the header content here</div>'

    If you have no header.php then it will be likely be the index.php you need to look in for this mark up.

  5. moshu
    Member
    Posted 8 years ago #

    1. If an index template file is not sliced in pieces - then everything is in there.
    2. A little bit of search doesn't hurt...
    http://wordpress.org/search/clickable+header?forums=1

  6. waynertrain
    Member
    Posted 8 years ago #

    maybe I'm retarded but I've searched everything and can't get it to work. right now my index.php file contains this code for the header:

    <div id="header">
    <h1>"><?php bloginfo('name'); ?></h1>
    </div>

    my style sheet code look like this:

    #header {
    height: 205px;
    background: url(/wp-content/themes/red-train/images/brandamgblog3.gif) no-repeat;
    }

    I have tried deleting the stuff between the h1 tags in the index.php file and including a link to the pic instead but that doesn't work either. most of the things recommended in the forums screw the page up. I'm desperate for some help here. I've only got 2 hairs left on my head. somebody please help. if you need the site in question, it's at brandamgblog.com

  7. waynertrain
    Member
    Posted 8 years ago #

    I figured it out. I just overlayed the image with a link over the header. It's ugly as far as the coding goes, but it works and you can't tell the difference visually. Thanks to all those that put some time forth to help.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags