WordPress.org

Ready to get started?Download WordPress

Forums

Leaflet Maps Marker (Google Maps, OpenStreetMap, Bing Maps)
[resolved] markers not instantly included in list (6 posts)

  1. photocoen
    Member
    Posted 1 year ago #

    using 3.2.2 and when adding a new marker to a layer, the marker is visible on the map, but is not listed on the list, I have to go the list markers, click edit marker and update to get it listed under the map.

    http://wordpress.org/extend/plugins/leaflet-maps-marker/

  2. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Coen,
    I am having troubles reproducing this issue. I check layer map/list of markers on backend and frontend: each time I added a new marker, the list was updated everywhere. are you sure it can be reproduced?
    would need to check that by myself... (please update to 3.3 before trying again).
    regards,
    Robert

  3. photocoen
    Member
    Posted 1 year ago #

    Updated to 3.3 and got rid of the error displaying about the readme.txt files.

    New marker appears on the list immediately, just a bit confusing about the way to list them.

    I've got a list of campspot's and I want to display them in a list under the map in order of time we visited a spot. But sometimes we visit a spot twice in time and maybe some information needs to be updated. So I have changed the "list of marker settings"

    Order list of markers by: -updated on
    Sort order: - descending [never know which one to tag,]

    Now my markers look nice and okay. But when I add a new marker, it is listed on the bottom of my list instead of on the top. Only when I edit the marker and update it again, it appears on the top? This shouldn't happen or should it?

    Adventurous greetings,
    Coen

  4. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Coen,
    ok - I know whats the problem: the plugin has to fields in database: created on and updated on. If a new marker is created, updated on is empty. It only gets added when saving the second time...dont know how to best deal with it...
    regards,
    Robert

  5. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    Hi again,
    I think I know how to fix this - will be included in the next release
    regards
    Robert

  6. RobertHarm
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Joen,
    I just release v3.4 which fixes this issue.
    best regards,
    Robert

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic