WordPress.org

Ready to get started?Download WordPress

Forums

Markdown href bug (4 posts)

  1. maphew
    Member
    Posted 9 years ago #

    Does anybody else have Markdown working with plain-style href links?
    Whenever I put in link like <http ://mappa.mundi.net> the text is stripped from the output version while the edit version has </http> appended to the text. Multiple links mean multiple </http> appends.
    I'm using WP1.2 and Markdown php v1.0, Sat 21 Aug 2004
    Actually, I'd much rather not have to use angle brackets at all. Why not just convert a bare address to a clickable link just like most email programs do? e.g. http://wordpress.org becomes

  2. MattRead
    Member
    Posted 9 years ago #

    Are you putting a space between the http and the ://, because there shouldn't be a space. Like this: <http://mappa.mundi.net>

  3. maphew
    Member
    Posted 9 years ago #

    eep, no, there are no spaces in my wordpress articles, just in the forum message (though how I managed to do that I don't know).

  4. Anonymous
    Unregistered
    Posted 9 years ago #

    Hum, this problem arrise because WordPress calls a function called "balanceTags" on your post before it is filtered by Markdown. This function assume that the URL is an unclosed HTML tag and close it with a </html>.
    The idea is not bad really, except that it should be done *after* Markdown has filtered the text.
    You can solve this problem by unchecking the "WordPress should correct invalidly nested XHTML automatically" box in Option > Writing from the admin page. You will lose the automatic check for balenced tags, but at least URLs will work correctly.
    -- Michel Fortin

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.