WordPress.org

Ready to get started?Download WordPress

Forums

MapPress Easy Google Maps
Maps only showing in Chrome, not IE, Firefox, Safari (10 posts)

  1. msebald
    Member
    Posted 1 year ago #

    Hello all,

    I installed MapPress today and I really love it. But I have something strange going on: If I put maps into TablePress tables, the maps are only shown on Chrome browser, not not on IE, Firefox, Safari (iPad). An example is here:
    http://www.sidemount-tauchen.com/ausruestung/verkaeufer/

    If I put a map into a blog article, it shows on all browsers, example:
    http://www.sidemount-tauchen.com/2013/01/03/sidemount-workshops-in-ehningen/

    Any idea, clue?

    Thank you very much for your help,
    Cheers,
    Martin

    http://wordpress.org/extend/plugins/mappress-google-maps-for-wordpress/

  2. TobiasBg
    Member
    Posted 1 year ago #

    Hi Martin,

    thanks for your post, and sorry for the trouble.

    From what I can see, the MapPress plugin is not embedding its JavaScript into the page when the Shortcode is evaluated in a table. From TablePress' point of view everything that is necessary for this is being done, so my assumption is that MapPress is doing something extra when a MapPress Shortcode is inserted into post or page. Instead, it should be doing this whenever its Shortcode is evaluated.

    Regards,
    Tobias

  3. msebald
    Member
    Posted 1 year ago #

    Hi Tobias,

    I see and that could be the clue. Funny thing is that it is working without this code with Chrome...

    Hm, what could I do exept adding a extra map to the page/post which kinda looks strange as it should not be there.

    Cheers,
    Martin

  4. TobiasBg
    Member
    Posted 1 year ago #

    Hi Martin,

    I just thought of another possible reason for this. It might be due to the Table Output caching in TablePress. As the table contents are cached, the MapPress Shortcode is not actually evaluated, and due to that, its JS is not loaded.
    This is working for you in Chrome, because you are logged-in into WordPress in Chrome, and then the Table Output Cache is not used.

    So, the fix might be to deactivate Table Output Caching for this table in TablePress, by simply changing the Shortcode from something like

    [table id=123 /]

    to

    [table id=123 cache_table_output=false /]

    Sorry for pointing you in the wrong direction in my first post...

    Regards,
    Tobias

  5. msebald
    Member
    Posted 1 year ago #

    Hi Tobias,

    great, it works now! That was the clue. Cool! :-)

    Thank you so much! :-)

    Cheers,
    Martin

  6. TobiasBg
    Member
    Posted 1 year ago #

    Hi,

    ah, very cool :-) Great to hear that this fixed it!
    Thanks for the confirmation.

    Best wishes,
    Tobias

    P.S.: In case you haven't, don't forget to rate the plugins here in the Plugin Directory. Thanks!

  7. manab_27
    Member
    Posted 1 year ago #

    my mappress images are not showing in IE and the pins are also not showing in any browser. Please help.

    http://blogs.prayag.com/SBICAPS_option3/about-us/location/

  8. TobiasBg
    Member
    Posted 1 year ago #

    Hi,

    that's indeed strange. It's not working for me either. However, I also don't get any JavaScript errors in Chrome...

    Regards,
    Tobias

  9. manab_27
    Member
    Posted 1 year ago #

    Give me a suggestion. Shall I use another plugin.
    Can you suggest me anyone that perfectly suits my purpose.
    http://blogs.prayag.com/SBICAPS_option3/about-us/location/

  10. TobiasBg
    Member
    Posted 1 year ago #

    Hi,

    sorry, I don't have a suggestion here :-( I'm not familiar with Maps plugins or debugging this. Sorry.

    Regards,
    Tobias

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic