WordPress.org

Ready to get started?Download WordPress

Forums

mapping domains issues, wp 3.2 (6 posts)

  1. cityCat007
    Member
    Posted 3 years ago #

    Hello,
    I'm trying to create a network using wp 3.2

    my structure so far is like this:

    mysite.com/sub-directory-site1
    /sub-directory-site2
    and so...

    domain1.com mapped to /sub-directory-site1
    2 to 2...

    OK, so far everything is ok as I basically have it working, BUT my problem is that when I type domain1.com it goes to mysite.com/sub-directory-site1 (showing that full url)... and I believe it should not as I have this configuration at
    >Domain Mapping >Domain Options :
    [ ] Remote Login
    [V] Permanent redirect (better for your blogger's pagerank)
    [V] User domain mapping page
    [V] Redirect administration pages to site's original domain (remote login disabled if this redirect is disabled)
    [ ] Disable primary domain check. Sites will not redirect to one domain name. May cause duplicate content issues.

    IF at Domains I check Primary for each domain, it work as expected (not redirecting to mysite.com/sub-directory-site1 when I open domain1.com but actually loading the page at domain1.com)
    BUT as I understand this Primary option is for ONLY one primary domain (in this case, supposedly mysite.com) this solution dosnt really satisfy me much.

    another thing is that I cannot define mysite.com (site id 1) at Domains. mysite.com is not another domain I want to add to my blog network but is the domain in which the blog network is installed... but I read all over the net this "primary domain" should be the network one ¿?
    so I cannot define the primary domain that I understand would be the right primary domain, may be this the reason why I'm having problems??

    -------------------
    hope I explain my problems ok and there's some fix/explanation to what Im doing wrong or so...
    thanks in advance :)

    Gonzalo.

  2. Was duplicated here: http://wordpress.org/support/topic/mapping-domains-all-domains-set-as-primary?replies=2&message=closed

    Please note - The MultiSite domain expert is on vacation right now, and alas, I don't actually use it.

    Having skimmed http://ottopress.com/2010/wordpress-3-0-multisite-domain-mapping-tutorial/ I note that Otto says :

    All you really do is put in a new domain and set it as the primary. Simple.

    I think you're fine setting the domain as primary per site. The non-primary would be if you wanted to park another domain atop it, I think.

  3. cityCat007
    Member
    Posted 3 years ago #

    thank you Ipstenu, and please excuse my impatience and such..

    really my biggest worry is that set all the domains as primary could case any trouble, as this is the solution I found so far.

  4. It shouldn't. I did a fast test and it worked fine :)

  5. brent3721
    Member
    Posted 2 years ago #

    I also followed all the steps on otto's blog and it works good but even though I set my domain to primary I can still hit the site on the old sub domain url as well... here's my settings:

    Remote Login
    X Permanent redirect (better for your blogger's pagerank)
    X User domain mapping page
    Redirect administration pages to site's original domain
    Disable primary domain check. Sites will not redirect to one domain name. May cause duplicate content issues.

    the two urls are:

    http://uk.toughmudder.com/
    and
    http://toughmudder.co.uk

    I'd expect going to the subdomain to forward me to the .co.uk domain I mapped and set as primary... anything I'm missing?

    many thanks in advance for any help you can give

    b r e n t

  6. brent3721
    Member
    Posted 2 years ago #

    OMG figured it out finally, I'm going to post here to maybe save others countless hours of time... So if you're a newbie to the network setup, which you probably are if you're following this tutorial, you might not understand what it means to 'network activate a plugin' when I went through that part of the tutorial I just activated the plugin on my main site's plugins page (since it was there) and moved on. Instead of doing that you MUST active it for the network by going into the super admin area and then plugins...

    brent
    @
    mimoYmima.com

Topic Closed

This topic has been closed to new replies.

About this Topic