WordPress.org

Ready to get started?Download WordPress

Forums

TablePress
[resolved] Manually delete table IDs (10 posts)

  1. MRA_Andy
    Member
    Posted 1 year ago #

    Hi Tobias,

    I was trying to import a huge zip file with tables and it failed to complete the upload. However after that the "All tables" page wouldn´t load anymore.
    So I deleted all entries from the upload in the wp-posts and wp-postmeta table manually and "All tables" page was good again, but...
    It appears that the entries are still there, because the deleted tables now show up with the title "(no name)" and can not be deleted in the "All tables" list because the entry was -of cause- deleted in the wordpress-database.
    Is there anything I can do to make those "(no name)"-tables disappear?

    Thanks in advance.

    http://wordpress.org/extend/plugins/tablepress/

  2. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    thanks for your post, and sorry for the trouble.

    This sounds like a problem with the Memory Limit or the execution time. However, I find it weird that the "All tables" screen was affected by this. Did you get any error messages or have any in the server's error log?
    (A workaround for the import problem with the huge ZIP file might be to just extract it on your hard drive, and create several smaller ZIP files from the individual table files.)

    Now, to fix the "(no name)" entries: Navigate to

    http://example.com/wp-admin/options.php

    (with example.com being your site). Scroll down to the entry "tablepress_tables". Change its value to

    {"last_id":0,"table_post":[]}

    Scroll down and click "Save Changes".
    After that, all tables should be gone.

    Regards,
    Tobias

  3. MRA_Andy
    Member
    Posted 1 year ago #

    Thank you very much, worked perfect.

    I didn´t delete all the tables, just set last_id back to the value before the upload and deleted the table_post pairs for the failed upload.
    Will make smaller zips now...
    The "All tables"-page stayed white and didn´t load anymore, maybe too much tables in the system? I will upload step by step now and watch how the memory and loadingtime develops.

    Andy

  4. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Andy,

    no problem, you are very welcome!

    Of course, if you hadn't deleted all tables in wp_posts, removing only the no longer existing ones from that "tablepress_tables" entry is correct :-)

    The white "All tables" page indicates that some limit was reached. There's probably an error message in the server error log.

    And just so that I have a number: How many tables where in that initial large ZIP file?

    Best wishes,
    Tobias

  5. MRA_Andy
    Member
    Posted 1 year ago #

    Hi Tobias,

    I had 77 tables in the system. Then I tried to upload a zip of 253 tables with some of them up to 500kb in csv-utf8-format but the majority between 1-10kb. The zip was 1.5mb.
    Hope that gives you some indication. As I said, I will make smaller zips now and report if anything like this occures again.

    Have a nice weekend
    Andy

  6. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Andy,

    thanks for the further info. Yes, this might then probably lead to the memory limit being reached.
    I'm currently exploring some techniques to make the "All tables" screen more robust and faster on site with many tables, so that should bring some improvement in the future.

    Smaller ZIPs should at least allow you to import your data for now.

    Best wishes and Happy Holidays!
    Tobias

  7. MRA_Andy
    Member
    Posted 1 year ago #

    Hi Tobias,

    don´t want to disturb your Holidays, just want to give you an update on the data limit problem.
    I´ve uploaded tables one by one until the limit and now the screens of "All tables", "Import" and "Export"-page do not load anymore. I don´t get any error-message.

    uploaded tables: 185
    offline data as csv-utf8-files: 3,36mb

    Hope thats some useful information.

    Andy

  8. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Andy,

    thanks for the info. All of those pages show the list of tables in some way, so I assume that the memory limit is reached when this list is loaded from the DB.
    To verify this, can you temporarily set the "WP_DEBUG" constant to true in your wp-config.php? After that, the "All tables", "Import", and "Export" screens should no longer remain white, but show an error message.

    Thanks!
    Tobias

  9. MRA_Andy
    Member
    Posted 1 year ago #

    Hi Tobias,

    did some research on the Internet today and found that too. As my searchpage is broken as well (no results, just white page) I assume that there is the same reason for it. Of course the search uses all tables as well and this is not within the memory limit. I didn´t change anything and tried to increase the memory limit but found that my provider won´t let me do... then suddenly I tried a search request and got no white page but an error message:

    Fatal error: Out of memory (allocated 105381888) (tried to allocate 35 bytes) in **************************/wp-content/plugins/tablepress/controllers/controller-frontend.php on line 523

    after that I tried to load the "All tables" page and got

    Fatal error: Out of memory (allocated 104595456) (tried to allocate 3 bytes) in **************************/wp-content/plugins/tablepress/models/model-table.php on line 161

    To give you further detailed information can I contact you under your Mail address on your webpage http://tobias.baethge.com/imprint/ ?

    Happy Holidays and thank you for your support so far.

    Andy

  10. TobiasBg
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Andy,

    thanks for this research! This is really helpful!

    Yes, please contact me via email with more detailed information!

    Now, I have a few ideas in mind that should reduce the amount of used memory on these screens, and I will try to implement and test them in the next few days.
    Meanwhile, sorry for the trouble :-(

    Happy Holidays!
    Tobias

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic