WordPress.org

Ready to get started?Download WordPress

Forums

Backup
[resolved] Manual backup question (5 posts)

  1. patrickdickey
    Member
    Posted 1 year ago #

    I installed the plugin, and configured everything but the Google Drive authorization and saved changes. It did the manual backup, but obviously didn't send anything to my Google Drive. I then authorized it with Google Drive, and tried to do the manual backup again (using the link for the cron job). According to the settings page (and my Google Drive) no backup was performed.

    Also, I followed the reply in one of the other "Manual Backups" thread (saving changes with the option as daily, and then setting it to never, saving changes, then setting it back to daily, and saving changes) but no manual backup was performed.

    My question is how do I perform a manual backup again, so I can update my wordpress installation? I realize that one was performed already, but I want to make sure it's done off-site as well as in the wordpress backup folder (just in case my entire wordpress installation and folders are wiped out).

    If possible, a button or link that performs a manual backup would be a great addition to the plugin.

    Thanks, and have a great day:)
    Patrick.

    http://wordpress.org/extend/plugins/backup/

  2. hel.io
    Member
    Plugin Author

    Posted 1 year ago #

    Manual backups are done using the cron link you wrote about. Whenever you access that URL it does a backup.

    As for why backups are not uploaded to Google Drive, please check the log file and paste the relevant lines here. You can see the last 10 lines from the log right within the plugin settings page. Just click on Screen (top right, next to help) and select Log File.

  3. patrickdickey
    Member
    Posted 1 year ago #

    Ok, I had updated my wordpress (and deactivated all of my plugins prior to that), so all of my settings were erased. I authorized and then set up everything the way I wanted it, and clicked "Save Changes". Then I refreshed, and got these lines in the log:

    2012-06-16 09:46:05 NOTICE Attempting to dump database to /home/dckysrvc/public_html/wp-content/backup/dump.sql
    2012-06-16 09:46:05 NOTICE The database dump was completed successfully in 0.28 seconds.
    2012-06-16 09:46:05 NOTICE Attempting to create archive /home/dckysrvc/public_html/wp-content/backup/1339821965.zip
    2012-06-16 09:46:10 NOTICE Archive created successfully in 5.23 seconds. Archive file size is 13 MB
    2012-06-16 09:46:11 NOTICE Attempting to upload archive to Google Drive
    2012-06-16 09:46:12 ERROR Received response code '400 Bad Request' while trying to get 'https://docs.google.com/feeds/default/private/full/WordPressBackups'. Response body: <errors xmlns='http://schemas.google.com/g/2005'><error><domain>GData</domain>InvalidEntryException<internalReason>Invalid document id: WordPressBackups</internalReason></error></errors> (bad_response)
    2012-06-16 09:46:12 NOTICE Backup process completed in 6.61 seconds. Initial PHP memory usage was 31.75 MB and the backup process used another 6 MB of RAM.

    So, apparently I need the document ID for my folder on google drive? Not the folder name.

    Thanks, and have a great day:)
    Patrick.

  4. patrickdickey
    Member
    Posted 1 year ago #

    Yep. That's what it was. You have to put the document ID for the folder in (the portion after #folders/ in the link when you open the folder). Then it works.

    Thanks.
    Patrick.

  5. hel.io
    Member
    Plugin Author

    Posted 1 year ago #

    I'm glad you figured it out. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic