WordPress.org

Ready to get started?Download WordPress

Forums

Manage ==> Categories not working in 2.1.2 (or 2.1.1 (14 posts)

  1. sorange
    Member
    Posted 7 years ago #

    Hi,

    I have been having problems adding and deleting Categories (of blog posts) from the Dashboard.

    If I delete a category it seems deleted, only to find later the deleted category is still on the list. If I go to add a new category, hitting the "Add Category" button does absolutely nothing.

    Is this possibly related to an issue I'm also having where I can't navigate to categories when on the blog?

    FWIW, I've had to gut my last two installations, deleting all but the My_SQL database. Also, I had to change server settings a couple of times - was hosted on a server in Hong Kong (using the machine address rather than my domain name while in development), moved to a U.S.-based machine URL, then finally to my own domain. Could this have possibly screwed something up?

  2. adcastillo
    Member
    Posted 7 years ago #

    I am having the exact same problem.

  3. thejimmeister
    Member
    Posted 7 years ago #

    I am using version 2.1. I am new to wordpress so I do not know if it is 2.1.0 or a newer version. I also cannot add a new category. I agree with Sorange that the "Add Category" button seems to do nothing.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    A lot of the new wordpress functionality uses AJAX requests. So if you are blocking javascript or have adblockers or privacy blockers working, then these buttons may not actually work properly. Disable any such software and clear/reload your browser cache before trying again.

  5. adcastillo
    Member
    Posted 7 years ago #

    I checked and none of the things you mentioned are blocking anything or being blocked. But yes it does seem like it is the AJAX that is not working.

  6. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    It's also possible that some older themes or plugins are incompatible, and it's entirely possible that they can interfere with this sort of thing. Look for any plugins/themes that use scriptaculous files and remove them. Failing that, disable plugins and see if you can figure out what is interfering.

  7. thejimmeister
    Member
    Posted 7 years ago #

    I am using K2 for my theme. Does it seem likely that K2 would be incompatible?

  8. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Yes. Extremely likely for the case of K2 if you upgraded to 2.1 without upgrading the theme as well. Make sure you get the latest version of K2. It must be the 2.1 compatible version.

  9. adcastillo
    Member
    Posted 7 years ago #

    OK, I did have scriptaculous installed but wasn't it using it for anything. I deleted it and things seem to work better but still not like they should. When I add a new tag it doesn't automatically appear in the list. I have to hit reload on my browser to see it.

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    WordPress includes scriptaculous in it now, so if that was loading elsewhere, the function names would interfere and such.

    Also, make sure you clear your browser cache after correcting the problem. Javascripts can be cached and still interfere even when they're no longer on the server.

  11. adcastillo
    Member
    Posted 7 years ago #

    Woot! I finally got it to work. I deleted:
    addEvent.js
    moo.fx.js
    moo.fx.pack.js
    prototype-1.4.0.js
    prototype.js
    prototype.lite.js
    quicktags.js
    sweetTitles.js

    and now it works like it's supposed to. Thanks!

  12. adcastillo
    Member
    Posted 7 years ago #

    Oops, except on the page where you edit or enter a post, there is no longer an option to add a category. Was I not suppose to delete one of those?

  13. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    I don't know what any of those files are. Make sure you have all the files that are included in the default WordPress download.

  14. zivanet
    Member
    Posted 7 years ago #

    For me this problem of categories not deleting was all because of browsers and javascript settings. I always post using Firefox because IE is too problem-laden. Even in Firefox I could only get categories (and pages) to delete and stay deleted when I first turned off Java and Javascripts and popup blocker in Firefox (under tools -> options). However, to be able to drag and drop widgets into sidebars I had to turn Java and Javascripts back on again. I didn't take the time to find out which of these tools functions was really the most important - I just toggled them all off and then back on again.

Topic Closed

This topic has been closed to new replies.

About this Topic