WordPress.org

Ready to get started?Download WordPress

Forums

MAMP now what? (14 posts)

  1. FAMOsa
    Member
    Posted 1 year ago #

    I am trying to create my wordpress site on my hard drive and then when it is finished, I will upload it to my site. I have installed MAMP and wordpress. When I click on the MAMP icon, I can go to interesting places, like phpinfo, myphpadmin, xcach, and sqlite manager. The myphpadmin looks the most promising as it has "wordpress" in the list in the lefthand column. But how do I get from this page to the groovy wordpress page that has the dashboard, themes, etc?? Thank you all for your help.

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    Have you reviewed installing WordPress locally?

  3. prosefectionist
    Member
    Posted 1 year ago #

    If you follow the "Install WordPress Locally on MacOS X with MAMP" instructions, things have actually gotten a bit easier.

    After you've created your database, you can navigate directly to your new wordpress installation in your browser (i.e. localhost...), and WordPress will ask you for the database information and try to set up its own configuration file.

    Also, you can ignore the bit about connecting to MySQL through your own scripts.

  4. radhika
    Member
    Posted 1 year ago #

    Firstly you have to move the wordpress folder (Application/MAMP/htodocs/). And follow this link installing wordpress.

  5. FAMOsa
    Member
    Posted 1 year ago #

    I've installed MAMP successfully on my Mac, following the instructions in Installing WrodPress locally on your Mac win MAMP. Step 4 is Downloading and Installing WordPress. WordPress in already downloaded in the same application folder as MAMP (I just used the default location when WordPress asked me where to put the file. It is in applications/MAMP/htdocs) Anyway, the last instructions in Step 4 are:

    Once that's complete, enter a blog name and email address, and you're ready to use WordPress on your Mac.

    I don't know where to put my blog name and email address.

    Thank you for all your help.

  6. prosefectionist
    Member
    Posted 1 year ago #

    Once you have MAMP running and you have your wordpress folder in /htdocs, then navigate in your browser to localhost:8888/wordpress/ and that's where you'll enter your information.

  7. FAMOsa
    Member
    Posted 1 year ago #

    You guys are really patient. I'm trying to think of something nice to do for you all. I decided to delete everything and start from the beginning. Again, I am following the directions in "Installing WordPress Locally on Your Mac using MAMP"
    First of all, it tells me to install MAMP and not MAMP Pro, but there is no button to just install MAMP. It installs them both. Then it gives directions on how to drag them into the Applications folder, but when I open the little package from my downloads file, I go into a little Mac installation wizard that puts them nicely into my applications folder.

    Then it tells me to click the preference button and enter the settings (8888 & 8889). These were already in there. Then it tells me to go to php and select version 5. The only 2 options are 5.2.17 and 5.4.4. and the latter (5.4.4) is selected. I clicked OK, because generally I just use the default settings. Then it tells me to click on Apache and select a root document. Again I just use the default which was Applications/MAMP/htdocs.

    Then I downloaded WordPress. It went into my download file. I opened another finder window and put all the wordpress files into Applications/MAMAP/htdocs.

    This is where I always mess up. It says visit your local site. What may be the problem is that I have both Safari and Firefox installed on my computer. When I click on the MAMP icon in my Applications folder, it always opens in Firefox. Right now, for example. I am writing this post in Safari and MAMP is running in Firefox.

    Now the codex document tells me this:
    Lastly, we've got to run WordPress' famous 5-minute install. Visit your local site (localhost:port or localhost:port/wordpress), and enter the following information into the database setup form:

    In my Firefox URL window, it says http://localhost:8888/MAMP/?language=English
    When I try putting in localhost:port or localhost:port/365 (365 is the name of the database I created) I get an "address was not understood message"

    So this is how it is. If any of you are close enough, I'll bake you a cake.

  8. prosefectionist
    Member
    Posted 1 year ago #

    No worries - getting everything working the first time is often the hardest part.

    There are a couple things I think you may be doing wrong.

    First, put the whole wordpress folder into htdocs. Call it whatever you want. Let's assume you just call it 'wordpress'.

    Make sure you have MAMP running.

    Now in your browser go to localhost:8888/wordpress/ (assuming you called the folder 'wordpress.'

    That will bring up a wordpess setup page. On that page, you will enter your database info and other stuff. You don't put the database name into the address bar itself.

    Depending on your settings, you may also want to try localhost/wordpress/ (without the port number). You also don't use the word 'port' in the address bar.

  9. FAMOsa
    Member
    Posted 1 year ago #

    wordpress is what the folder was called anyway, so yes, the folder is called "wordpress"
    I put "localhost:8888/wordpress" in the Firefox URL bar and get Error in establishing Database Connection

  10. prosefectionist
    Member
    Posted 1 year ago #

    Sorry, not really sure what the issue is in that case. This seems to crop up a lot, so you could look at the threads here: http://wordpress.org/tags/error-establishing-a-database-connection

    One thing you could check is whether you somehow already have a wp-config.php file in your wordpress folder. If so, you should open it up and make sure that the information there is correct. (eg database name, password, etc.)

  11. FAMOsa
    Member
    Posted 1 year ago #

    Actually, I already changed wp-config-sample to wp-config.php. In Firefox I can click on File, then go to open file, and then go to wp-config.php. When I click on it, I get a dialog box that gives the options: Open With (with a button to choose what program to open it with) or Save File

  12. prosefectionist
    Member
    Posted 1 year ago #

    Ok, well that sample file will get you database errors unless you've actually modified it, which it sounds like you haven't. You can either modify if with your information, or delete it/rename it, and then go back to localhost:8888/wordpress in the browser, and it should try to create the config file for you.

    If you want to modify the config file yourself, you'll want a good text editing program like TextWrangler.

  13. FAMOsa
    Member
    Posted 1 year ago #

    Well, my friends. I've figured it out, but I've no idea how. I tried to open wp-config.php and it took me to this page that said, you don't have config, but we can help you find it. I clicked on the button and it asked me some questions like username (root) and password (root) and finally I got to the dashboard of my wordpress site/blog.

    Then I closed everything up and tried to replicate it. I got nowhere until I opened Firefox and put this in localhost:8888/wordpress/wp-login.php

    That takes me to the place where I can put in my username (admin) and password (i'm not telling you) and I can go in and look at my site and make changes with the dashboard.

    I feel somewhat like Alice in Wonderland. Instead of "Drink Me" it said "Click Here" and has brought me into another new land.

    Thank you to those of you who tried to help. I think I have a later version of OSX and MAMP and the codex document did not have instructions for the latest ones. Now that I've installed it, I'm on to other forums to get new themes, etc. Unless when I come home in a few hours, try to start it up again, and find it has vanished like a dream. Then I'll be back on the installation forum begging for help again.

  14. prosefectionist
    Member
    Posted 1 year ago #

    Well, good. That's what you should have seen right away, but I'm glad you got it working.

    Yes, some of those guides are rather out of date.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.