WordPress.org

Ready to get started?Download WordPress

Forums

MAMP multisite activation causes redirect loop (5 posts)

  1. Runtheball
    Member
    Posted 1 year ago #

    I just set up MAMP and installed WP with everything running fine, until I activated multisite. Now I'm getting the "This webpage has a redirect loop" message. On activating multisite, I just copied and pasted the code provided within the WP multisite activation screen, which is also shown at http://codex.wordpress.org/Multisite_Network_Administration
    The wp.config changes seem pretty straightforward. I have the following (excerpt)
    define('DOMAIN_CURRENT_SITE', 'localhost:80');
    define('PATH_CURRENT_SITE', '/nameofmysite/');
    I don't think anything is wrong there, but I don't understand the .htaccess code and so maybe I needed to change something from the code provided? If that code is appropriate, then what does 'this webpage has a redirect loop" actually mean? And where do I look for the solution?

  2. Runtheball
    Member
    Posted 1 year ago #

    Still struggling with this. Googling similar issues and re-reading the Multisite_Network_Administration codex page I've discovered that I do not have the following bit of code in my httpd file...

    <VirtualHost *:80>
    DocumentRoot /var/www/vhosts/wordpress
    <Directory /var/www/vhosts/wordpress>
    AllowOverride Fileinfo Options
    </Directory>

    Problem is that I do not understand this code at all. the other virtual host entries that I've added have a </VirtualHost> at the end of them, bu the above doesn't. Is it incomplete? Am I supposed to put something in here to customize this for my setup? Of course I'd need to correct the documentRoot to point to my installation location, but other than that what do I need to do with this code, and what does the code actually mean?

  3. CNG SEO UK
    Member
    Posted 1 year ago #

    define('MULTISITE', true);

  4. CNG SEO UK
    Member
    Posted 1 year ago #

    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

  5. Runtheball
    Member
    Posted 1 year ago #

    I appreciate your response, but I already have that code in my wp-config and htaccess files.

Topic Closed

This topic has been closed to new replies.

About this Topic