Ready to get started?Download WordPress


WP Flexible Map
[resolved] Making KML file work (3 posts)

  1. Southwest
    Posted 1 year ago #

    Thanks for this plugin; it's a nice alternative to a plugin I was trying to use previously that just wouldn't work.

    I'm trying to make a map from a KML file I created in Google Earth, and uploaded via FTP to my site's wp-content directory. Here's the shortcode I'm using:

    [flexiblemap center="35.030017,135.760722" width="600" height="350" src="http://associatedkyotoprogram.dreamhosters.com/wp-content/uploads/resources/maps/akp-doshisha-campus.kml"]

    The KML file has three points marked on it, with three custom markers. However, on the page itself, I don't see any of those.

    What do I need to do so that the plugin loads the KML file properly, adding all three points and the custom marker icons to the map?

    Thanks a bunch.


  2. webaware
    Plugin Author

    Posted 1 year ago #

    G'day Southwest,

    Because you've specified a centre point, a centre-based map is used instead of a KML-based map. In a future version, I'll allow the centre to re-centre a KML based map, but for the meantime if you need that you'll have to add some JavaScript to your page; see this related support post.

    Also, your kml file has relative links to images, e.g.

    <href>icons/Kyoto subway logo.png</href>

    Change those to the full paths so that Google Maps can see them on the Internet.


    [edited to fix link to related support post]

  3. Southwest
    Posted 12 months ago #

    Thanks, Ross--I didn't realize that including a KML file would automatically position the map. Just by removing the center parameter, I was able to get the KML file's points to display.

    I also didn't change the relative file paths to full--but the relative paths are valid links, and the icons displayed properly.

    Thanks for the assistance!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic