WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Making blog homepage (16 posts)

  1. jhaber31
    Member
    Posted 4 years ago #

    I'd like to make my blog my domain's home page. However, before you answer, let me tell you my site structure.

    I have my own domain (hosted by fatcow), so this isn't a blog hosted by WordPress. Of course, WordPress is installed, and the blog exists in the subfolder blog. Thus, the blog address is http://www.haberarts.com/blog. Under settings, reading, I have checked that the front page displays my latest post.

    My domain's root folder contains a lot of other content not related to the blog, and to manage all this, I'd much rather keep the blog in a separate folder, as I've done. Links in the blog often take people to that other content. I think that means I can't use htaccess to redirect people to the blog, because then all links to my static content would be broken.

    Finally, my root folder's index page for now has a boring Flash animation that ends by opening the blog. I'm tired of the animation and would rather people see the blog first thing.

    In short, I'd still like people who to go http://www.haberarts.com automatically to see the blog folder, but without either (a) killing all content in the root folder or (b) moving the blog into the root folder. Can I still do this? Thank you.

  2. Samuel B
    moderator
    Posted 4 years ago #

  3. jhaber31
    Member
    Posted 4 years ago #

    Thanks very much. I think I mostly follow. In effect, several of the steps won't be necessary, since WordPress ALREADY has its own directory. If I'm guessing right, that means that steps 1-3, 6, 10, and 11 won't be needed by other steps will. But I'll play around, and this sounds like a good guide to get me started. -- John

  4. jhaber31
    Member
    Posted 4 years ago #

    While you're being so helpful, can I anticipate some problems? I examined the WordPress index.php file in the blog directory. It's quite simple (in fact, much simpler than my index.html file in the root).

    Thus, first, after copying it into the root and editing it, I assume I delete it from the blog directory? Second, I assume I delete index.html, so there will be no index.html file in the root? And third, I assume I don't try to alter it further to make up for some of the functionality of my existing index file, such as meta tags within head tags? (These are specified in WordPress templates, I see.) Thanks, John

  5. Samuel B
    moderator
    Posted 4 years ago #

    Thus, first, after copying it into the root and editing it, I assume I delete it from the blog directory?

    shouldn't be any editing, but yes remove it from /blog.

    Second, I assume I delete index.html, so there will be no index.html file in the root?

    yes

    And third, I assume I don't try to alter it further to make up for some of the functionality of my existing index file, such as meta tags within head tags?

    if you want the meta stuff from the index.html, just copy it to your theme's header.php with the other meta tags and it will function the same

  6. Saildude
    Member
    Posted 4 years ago #

    I moved my "blog" to the root and moved most of the old web content into WordPress a few weeks ago. Copied and put the modified index.php file in the root per the guide. WordPress now drives my whole site except for one set up pictures. I left the old structure in place on my site and put redirects on those pages to send visitors to the proper post or page.

    I left the old index.php in it's /wordpress folder. My theory was that would make bookmarks from other sites would work without a problem into my site.

    Yes, delete or change the name of the index.html file in the root.

    Problems?? Well I can't spell and hacked up the path in the modified index.php file in the root, worked fine after I fixed the path.

    Yes it was a bit of an act of faith - back up any file you change just in case so you can go back while you find any problems.

    Good luck

  7. jhaber31
    Member
    Posted 4 years ago #

    Thanks. I'm going to restore a version of index.php to the blog directory, because I'm getting an error message without it. Will check back soon.

  8. jhaber31
    Member
    Posted 4 years ago #

    Ouch. So far I'm getting the worst of both worlds. If I go to my URL, http://www.haberarts.com/, then it plays the old splash screen anyhow, and then if I go to the blog as before, it correctly displays the template but says no posts match my criteria! I'm going to have to revert for a while until I can get more help or figure out what went wrong.

  9. jhaber31
    Member
    Posted 4 years ago #

    Oh, just to clarify. First, when I said I was restoring index.php to /blog, the error page I was seeing said that index.html (or that and a few other choices) was missing.

    Second, when I said I got the worst of both worlds, I see one of my mistakes. I deleted index.html from the copy of files on my computer, but not online. (Sorry!) That's why the splash screen showed. (I guess index.html has priority over index.php.)

    That still leaves the question of why I then was seeing that no posts matched my criteria once the blog page successfully loaded its template, with colors, menus, and so on.

  10. Samuel B
    moderator
    Posted 4 years ago #

    you need to set your permalinks now so the files will know the index.php is in root
    admin - settings - permalinks
    if you already have a structure - just re-save it

  11. jhaber31
    Member
    Posted 4 years ago #

    Thanks. Under permalinks I just have the checkbox for "Month and name." So I go to "custom structure" and add "/blog" at the head of the URL?

  12. Samuel B
    moderator
    Posted 4 years ago #

    So I go to "custom structure" and add "/blog" at the head of the URL?

    NO - do not do that
    just re-save what you have

  13. henkholland
    Member
    Posted 4 years ago #

    Should not be the blog folder in the path in the index.php in the root?

    /** Loads the WordPress Environment and Template */
    require('./blog/wp-blog-header.php');
    ?>

    And then under Dashboard/Settings/General
    the wordpress adress: http://www.yoursite.com/blog
    and the blog adress: http://www.yoursite.com

    That's my own setup anyway.

  14. jhaber31
    Member
    Posted 4 years ago #

    Henkholland, that's the setup I'm trying for yes. I was trying to debug what went wrong and, then, to understand the advice about updating permalinks to fix it. I shall try today and update status here, thanks.

  15. jhaber31
    Member
    Posted 4 years ago #

    Thanks so much again to the moderator for the help as well as the patience. I stretched this out over a day and missed the simple step of the save button. This definitely works.

    Let me ask one last question. For static pages in my hold directory, I'd a menu with links to the blog before. Now they'll be links simply home. Is the preferred syntax for that href="./" or href="/"? I realize I could specify href="index.php," but I remember the relative link as more economical.

  16. jhaber31
    Member
    Posted 4 years ago #

    Oh, forget it. I see it doesn't matter. Anyhow, thanks again, and I'll treat this all as resolved!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.