WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Make top level menu links inactive? (12 posts)

  1. stutes
    Member
    Posted 3 years ago #

    So I just set up a menu under Appearance > Menus, using the Atahualpa 3.5.2 theme, and I'm pleased to say it is working well (the menu was broken for a while).

    The only thing I miss is that now all levels of the menu are active, and I liked it before when the theme managed the menu and allowed me to make the top levels of the menu inactive. With WP3, the theme has given control of the menu to WP3, in order to be able to integrate the new menu feature in WP3.

    So I'm wondering how I can make the top levels of the menu inactive.

    For example, I have:
    Upcoming >
    Announcements
    Events
    Calendar

    The "Upcoming" is a page, but it is empty. There is really no content for it, it is just an empty page acting as a parent for the children.

    Before with WP2 no could click on it. Now people can, and all they get is an empty page.

    Any advice?

  2. Mark / t31os
    Moderator
    Posted 3 years ago #

    Rather then using empty pages, use the custom links box, and use # in the URL field, it'll be clickable, but not go anywhere, and you can give the item any name you like.. (without a need to create a page).

    If you don't see a "Custom Links" box, click on "Screen Options" (top right), and check the appropriate checkbox to enable custom links..

    Hope that helps.. :)

  3. stutes
    Member
    Posted 3 years ago #

    Thanks! Worked slick!

  4. Mark / t31os
    Moderator
    Posted 3 years ago #

    You're welcome.. ;)

  5. lmlm
    Member
    Posted 3 years ago #

    hello. i am dealing with the same issue, however i can't find the "custom links" box. i'm using wp 3.0.1

    what i am missing? thanks!

  6. stutes
    Member
    Posted 3 years ago #

    Are you under Appearance > Menus?

  7. lmlm
    Member
    Posted 3 years ago #

    i am under "Appearance", however there's only 3 options available: Themes, Widgets and Editor

  8. stutes
    Member
    Posted 3 years ago #

    Don't know what to tell ya. Under "Appearance" I have the following in this order:

    Themes
    Widgets
    Menus
    Atahualpa Themes Options
    Editor

    As you can see, I use the Atahualpa Theme, which I had to update to get to work with WP3. Perhaps the lack of Menu showing up under Appearance is because your theme doesn't support the WP3 menu system. Like I said, I had to update my theme before I could get the new menu system to work.

  9. Mark / t31os
    Moderator
    Posted 3 years ago #

    You probably need to add support for the menus to the theme.

    add_theme_support( 'nav-menus' );

    http://codex.wordpress.org/Function_Reference/add_theme_support

  10. esmi
    Forum Moderator
    Posted 3 years ago #

    @Mark: Last I heard from the core team, add_theme_support( 'nav-menus' ) wasn't to be used in themes (it's for internal use only). You need to call register_nav_menus instead.

  11. Mark / t31os
    Moderator
    Posted 3 years ago #

    I've never had to add support to a theme(educated guess), hence my lack of knowledge on that key piece of info, thanks .. ;)

  12. lmlm
    Member
    Posted 3 years ago #

    thanks guys, since i am building a brand new theme, apparently i needed to force the menus to show up in my wp-admin. this simple code did the trick:

    <?php register_nav_menu(); ?>

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags