WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
[resolved] Make PDFs Private? (6 posts)

  1. myladeybugg
    Member
    Posted 1 year ago #

    I am looking to make a membership site with PDFs where the member has to pay to have access to the PDFs. But I cannot let them have any way of downloading or printing the PDF.

    Is there a way to keep the PDFs more secure and keep people from downloading or printing them?

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    If you want people to be able to view the PDFs in the viewer without downloading them, you can use the private document support in GDE 2.5.x. A full description of this feature and potential limitations is here:

    http://www.davistribe.org/gde/secure-docs/

    If you want to prevent viewing as well, you'll have to put the post containing the viewer in a protected member area as a whole. Can't say whether this will meet your needs or not, but hope this helps.

  3. myladeybugg
    Member
    Posted 1 year ago #

    Sounds like this could very well work. How would i go about making a protected area?

  4. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    You don't have to do anything special. In a clean install of GDE 2.5.x - adjust this appropriately if you've changed your available profiles - just add the usual GDE shortcode, but set the profile to "2" or "max-doc-security" like this:

    [gview file="http://url.to/file.pdf" profile="max-doc-security"]

    For added security you may wish to create a new folder using FTP, etc. to store all your otherwise "hidden" documents, and use that URL in the shortcode above. You can also increase security by blocking search engine indexing on that whole folder using robots.txt or whatever is appropriate for your server. But in general, just using this shortcode syntax will make the document inaccessible to the vast majority of users.

    Hope this helps.

  5. myladeybugg
    Member
    Posted 1 year ago #

    Wonderful, thank you!

    I installed everything, but am getting an error when viewing the PDF page:

    GDE Error: Error retrieving file - if necessary turn off error checking (401:Unauthorized)

    I tried uninstalling and re installing and still get the same error. I also turned of error checking, but still get an error. And for the shortcode I tried using the file name and the full URL.

  6. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    It appears you've placed your documents in a folder that requires login to access? This is not supported, as Google needs to be able to access the files for conversion. Please see the FAQ (Will it embed files that are password-protected or stored in protected folders/sites? and What about private documents?).

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.