WordPress.org

Ready to get started?Download WordPress

Forums

BlogoLife
Make homepage posts only show summary (7 posts)

  1. evermine77
    Member
    Posted 1 year ago #

    Hey there,

    So my second issue in as many days.

    I would like to only show a summary of my posts on the Home page, i ticked that option in settings but it doesn't work. I tried inserting <!--more--> where i wanted the break and that didn't work either.

    Can anyone help out here?

    Thx!

  2. victortihai
    Member
    Posted 1 year ago #

    Add the content in the excerpt field.

  3. jopsvanthof
    Member
    Posted 1 year ago #

    @Victor Tihai: where can I find the "excerpt field"?

    @ evermine77: the setting in [Settings] > [Reading] > [For each article in a feed, show] is only for (RSS) feeds, not for the home page. Inserting the <!--more--> tag in my post works for me, but you have to do it in the [Text] tab of the post editor. In the [Visual] tab of the post editor, there's a button "Insert More Tag - Alt + Shift + T" (it's between the "unlink" and "spell checker" buttons). Try that and let me know if it works.

    However, for me, the <!--more--> tag makes the homepage show a summary and a "continue reading tag". Yay! So far so good!

    The "continue reading tag" link points to the post's permalink, with an anchor (#more-5). In one of the default themes, this works fine... the anchor somehow gets inserted into the post by the WordPress "magic". In the Blogolife theme however, when I click the link, the post cannot be found. Even worse, the post's permalink WITHOUT the anchor doesn't work either... It seems like the post has vanished.

    I want to fix this WITHOUT using a plugin. So I'd rather change something in the (child) theme's php files. Anyone out there that knows how to fix this? Note that the BlogoLife theme has a rather complex structure with Backend (be) and Frontend (fe) folders and php files... :S

    PS. I LOVE the Blogolife theme!!!
    PPS. Dang... I wanted to add my website's URL to show you the problem. However, for the "live" website, I had to undo the excerpt change, so the site works. So I installed the Blogolife theme on another test site of mine... There it seems to WORK!!! So this seems to be an issue with my Blogolife CHILD theme that I have created... :( Still, any tips, tricks and hints where to look will be gratefully received!!
    PPPS. For what it's worth: the "live" site with child theme where the <!--more--> tag doesn't work, but where I now removed it is: http://www.projecticon.org. The test site is: http://www.vanthof.co

  4. victortihai
    Member
    Posted 1 year ago #

  5. jopsvanthof
    Member
    Posted 1 year ago #

    VERY interesting... I do not have that box/field with pages, nor with posts!! :S

  6. victortihai
    Member
    Posted 1 year ago #

    Edit the post and take a look at top right part of the page and you will see Screen Options.

  7. Nourhan Alaqad
    Member
    Posted 7 months ago #

    I used the excerpt field to add a summary to the homepage but the summary didn't appear. is there something I've missed doing ?

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic