WordPress.org

Ready to get started?Download WordPress

Forums

Make home page static (11 posts)

  1. grabrail56
    Member
    Posted 6 years ago #

    Hi
    I am completely new to WordPress and I am just going through setting up my first site.

    I would like my home page to be static so that when you come to my site, you see the same content every time. How do I achieve this.

    many thanks

  2. converting2wp
    Member
    Posted 6 years ago #

    1. Login to WordPress

    2. Go to the Administration > Write > Write Page panel

    3. Create the page content, then publish the page.

    4. Go to the Administration > Options > Reading panel

    5. Click the option for "Front Page Displays a Static Page".

    6. Select the page you created in step 3 from the drop down list.

    --------
    Optional: If you want some other page to display the "usual" list of blog posts.

    3.5 - Create the page that will have the blog posts.
    6.5 - Select *that* page in the Options > Reading panel as the "posts page"

    You can link to that from your home page or your navigation bar.

  3. lychyi
    Member
    Posted 6 years ago #

    This doesn't seem work for 2.0.11 or at least on the Reading options like the way you generally go about setting a static home page.

  4. mrkingid
    Member
    Posted 6 years ago #

    You should really upgrade to 2.3.1

  5. kgagne
    Member
    Posted 6 years ago #

    I don't believe static home pages were an inbuilt function until 2.1 or 2.2. For earlier installations of WordPress, upgrade :-) or use this plug-in:

    http://www.semiologic.com/software/publishing/static-front/

  6. dhanchey
    Member
    Posted 6 years ago #

    I did this and it worked...except...now I have my static home page titled Weird Things and I have a page titled Home, and they both have the same content. I like having Weird Things as my home page because I can edit it and that name appears in the blue bar at the very top of the browser.

    How do I get rid of the Home nav tab?

  7. bijer
    Member
    Posted 6 years ago #

    dhanchey, I had the same problem. My static home page was perfect until I started messing with the reading options. Here's what you can do.

    There seems to be a bug you can exploit. Name your static home page. Any name will do. Make it into a static page through reading options as described above.

    Then go back and edit that page, delete the title and add a space (I added three spaces and it works).

    That's all! The title of the page is still displayed but it's just space(s) so it's invisible.

    I'm using 2.3.2 but it worked in older versions too.

  8. moshu
    Member
    Posted 6 years ago #

    That's not the best solution.
    Usually, the problem with "double" homepage-link is due to a hard coded link in th header.php file. Just remove it and you should be fine.

  9. dhanchey
    Member
    Posted 6 years ago #

    I understand that I need to go into header.php and remove some code. Could you tell me exactly what code I'm looking for to delete? I've tried this before but forgot exactly what I did. Thanks.

  10. moshu
    Member
    Posted 6 years ago #

    You remove this line:
    <li><a title="Home is where the heart is" href="http://www.weirdthingsthathappened.com">Home</a></li> or whatever code is outputting it.
    Most likely it IS included in the code where your wp_list_pages tag is.

  11. dhanchey
    Member
    Posted 6 years ago #

    Thanks, I did that and it works perfectly!

Topic Closed

This topic has been closed to new replies.

About this Topic