WordPress.org

Ready to get started?Download WordPress

Forums

WordPress MU Domain Mapping
Make content available under differnet domain name instead of redirect (14 posts)

  1. rahra0
    Member
    Posted 8 months ago #

    For years I'm running a WP network on an Apache server. The WP sites are completely independent of each other.

    The primary (network admin) site is setup under a certain name (anafi.abenteuerland.at). All other blogs are setup to have a CNAME pointing to it.

    Now I need the content of one specific domain (www.cypherpunk.at) to appear under a different domain name. I already spent tens of hours but am unable to make this thing work.
    WP keeps the new name redirecting (302) to http://www.cypherpunk.at instead of showing the content.

    Best regards,
    Bernhard

    http://wordpress.org/plugins/wordpress-mu-domain-mapping/

  2. rahra0
    Member
    Posted 8 months ago #

    I could fix now the redirect by activating the "Disable primary domain check." check box. The page and most links work now under the new domain name but there are some links referring to the original domain name, such as e.g. the header image and several other images.

    What could I do to fix this?

    Thanx,
    Bernhard

  3. rahra0
    Member
    Posted 7 months ago #

    Any suggestions on how to fix the domain mapping for the media library files as well?

  4. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 7 months ago #

    the header image and several other images.

    What could I do to fix this?

    Domain mapping replacing links in the post/page content. It does not update links in the header, widgets, etc.

  5. rahra0
    Member
    Posted 6 months ago #

    If I insert an image into a post/page from the media library then the link to image isn't replaced by the domain mapping either. But shouldn't that be done?

  6. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 6 months ago #

    Did you edit the site in network admin and change the URL after you created the post?

  7. rahra0
    Member
    Posted 6 months ago #

    No, I didn't change the URL but I added an additional domain name to this site in the Network_Admin->Settings->Domains (of course after the posts where created).

    I just checked again and it seems that this issue has been fixed recently. Probably with the update from WP3.8 to 3.8.1. I'll check that and will give feedback here.

  8. rahra0
    Member
    Posted 6 months ago #

    It seems to work now, except for the header image. The path to the header image is stored in the wp_mu_XX_options table with a full path (including https://....). I removed the FQDN part directly in the table but this doesn't work for some reason because WP will show the default header image instead.

    You can have a look at the follwing URLs:

    https://www.cypherpunk.at/

    https://cypherpunk.abenteuerland.at/

  9. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 6 months ago #

    WP will show the default header image instead.

    The default header image for your theme is a hand drawn mathematical formula?

  10. rahra0
    Member
    Posted 6 months ago #

    No. The hand drawn formula is my custom header image. With "default" I meant the original image of the theme (which is a keyboard of a piano).

    I assume that either the theme, or the MU plugin, or WP itself could not locate the image anymore at all after I cropped the URL to an URI. Thus it seems to decide to fall back to the built-in default.

  11. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 6 months ago #

    That's probably an SSL issue.

  12. rahra0
    Member
    Posted 6 months ago #

    I'll setup a new fresh install without SSL for testing purpose and will post the results here again.

  13. rahra0
    Member
    Posted 6 months ago #

    It's extremely annoying. I'm unable to get this to work.
    I set up a completely fresh blog (within the existing network). I assigned two domain names which are CNAMEs to the primary name of the site/network (which is anafi.abenteuerland.at):

    http://w3test.abenteuerland.at/
    http://w3test.cypherpunk.at/

    Although it seems to work, Firebug clearly shows that everything is fetched from the first domain name except the initial request.

    As usual, I added two <VirtualHost> stanzas to the Apache configuration, one for each domain name.

    Regards,
    Bernhard

  14. Ron Rennick
    MultiSite Guru
    Plugin Author

    Posted 6 months ago #

    What I was saying was an SSL issue is that you couldn't get the header image (showing default instead).

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.