WordPress.org

Ready to get started?Download WordPress

Forums

Errors - ?> missng - blank page - no wp-admin access with 3.2.1 and php 5.3.3-7 (10 posts)

  1. webmaster-eddie
    Member
    Posted 2 years ago #

    Hello,

    I am an experienced webmaster but new to wordpress. I cannot get 3.2.1 to function properly on debian squeeze running php 5.3.3-7.

    I have tried 5 different sites - fast CGI, modPHP, suPHP(can't even install on suphp) and CGI . All using mysql db.

    All except the suPHP do install, and right away there is an error, clicking on the irst login link - whee the admin and password are provided to the system - takes me in all instances to a new login screen that doesn't work. If I clicn on the link at the bottom of that screen "Back to domain.com" It does take me to the site, logged-in as admin. However none of the links work - all lead to a blank page at that point.

    I have noticed that thee is no PHP closing tag ( ?> ) in the wp-config.php file. It is missing be default from the current download. However changing this and adding it does not fix the problem. Was this done on purpose?

    Also discovered there is no php end tag on cron.php

    Is this done on purpose, please?

    Thanks for any help - I have already tried everything suggested and nothing works.

  2. Tim S
    Member
    Posted 2 years ago #

    Some developers do not close the ?> since it is not needed. Closing the tag in the wp-config tag can cause issues. So you are correct, it does not close and should not be. I've installed WordPress multiple times on my VPS running suPHP without error. What is the exact error you are getting? Are you getting an error message?

  3. webmaster-eddie
    Member
    Posted 2 years ago #

    Thank you Tim for clearing up the question about the php end tags "omission" - I thought it was done on purpose.

    After installation for all different php-type sites except the suPHP type, I get 500 errors when clicking on any link in the admin or even when trying to login. Only static links work and only static pages resolve. Any dynamic pages do not resolve at all and I either get a blank page or a 500 error - depending on my server / php setup. FastCGI gives me the 500 page not found error and mod_PHP gives me the blank page error.

    Have you actually tried to install and configure a new wordpress site using the latest version freshly downloaded 3.2.1? I have spent too much time on this and am back to drupal - and lost a client who insists on a wp site.

    Thanks for your help in resolving this - i'd love to know if there is a problem with 3.2.1 or if my server configuration doesn't work with wordpress - all sites that fail are being tried on the same server - which runs everything else fine. My php setup can be found at
    http://lovemovies.biz/info.php
    or
    http://dating-connection.com/info.php

    Ed

  4. Tim S
    Member
    Posted 2 years ago #

    Typically, 500 errors are generic in nature. Look in the servers error_log file to see what is actually causing the error. It sounds as if you are having a permissions error. I'd check to make sure your files permissions and ownership is set correctly. I hope this helps!

  5. webmaster-eddie
    Member
    Posted 2 years ago #

    Thank you. I tied updating my php to 5.3.8 but that did not solve my problem. I may have uploaded the file by ftp from a server root login. That may have caused incorrect permissions to be set. Could you direct me ( or tell me) to where I can see what folder permissions are suppossed to be set to. For example is a 755 for the 3 main folders enough? And does that have to be set recursively into all subfolders, or just some of them?

    Thanks

    Eddie

  6. Tim S
    Member
    Posted 2 years ago #

    Hi Eddie,

    See if this link helps you:

    http://codex.wordpress.org/Changing_File_Permissions

  7. tristanbes
    Member
    Posted 2 years ago #

    I have exaclty the same problem but no one replied to my post.

    POST HERE

    PS: all the frontend works fine, it's just impacting the wp-admin !
    PPS: it's not rights problem. i chmod 777 the entired folders

    PHP 5.3.3-7+squeeze3 with Suhosin-Patch (cli) (built: Jun 28 2011 08:24:40)
    Copyright (c) 1997-2009 The PHP Group
    Zend Engine v2.3.0, Copyright (c) 1998-2010 Zend Technologies
        with Xdebug v2.1.0, Copyright (c) 2002-2010, by Derick Rethans
        with Suhosin v0.9.32.1, Copyright (c) 2007-2010, by SektionEins GmbH
  8. webmaster-eddie
    Member
    Posted 2 years ago #

    Hello,

    I still have the same problems for some wordpress sites - I put up 5 with different php configurations just to test this, and I finally got one working - a FastCGI site that I had woking, but then installed a number of plug-ins and that killed that site. I turned on error loggin by setting line 87 of my wp-config.php file to TRUE - and after reloading the page a few times in the browser was able to identify the plugins causing the errors and then just modified their directory names until I got the site up, but still can't get into the admin area properly, but I did get that site to load: still am seeing the ollowing errors with functions.php:

    Notice: load_plugin_textdomain was called with an argument that is deprecated since version 2.7 with no alternative available. in /var/www/clients/client1/web33/web/wp-includes/functions.php on line 3468 Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /var/www/clients/client1/web33/web/wp-includes/functions.php on line 3382 Notice: register_sidebar_widget is deprecated since version 2.8! Use wp_register_sidebar_widget() instead. in /var/www/clients/client1/web33/web/wp-includes/functions.php on line 3382 Warning: fopen(http://lovemovies.biz/wp-cron.php?doing_wp_cron): failed to open stream: HTTP request failed! in /var/www/clients/client1/web33/web/wp-includes/class-http.php on line 876 Notice: bp_core_is_multisite is deprecated since version 1.5! Use is_multisite() instead. in /var/www/clients/client1/web33/web/wp-includes/functions.php on line 3382 Notice: bp_core_is_multisite is deprecated since version 1.5! Use is_multisite() instead. in /var/www/clients/client1/web33/web/wp-includes/functions.php on line 3382 Notice: clean_url is deprecated since version 3.0! Use esc_url() instead. in /var/www/clients/client1/web33/web/wp-includes/functions.php on line 3382

    As for the other sites, I have noticed some major differences in the php.ini files I am using and that used on a large server co where I just had to rent a space to install a clients wordpress.

    For example, they have curl and dl installed and enabled and I do not. They also have magic_quotes_gpc and register_long_arrays set to on and I have them set to off. Do you think any of this could be the problem?

    As for you, tristanbes, if you are using FastCGI you need to modify the /etc/php5/cgi/php.ini file and if you are using mod_PHP then it's the /etc/php5/apache2/php.ini file. I believe that the /etc/php5/cli/php.ini is for the command line interface or interactive interpreter - you might need to adjust both or all 3 of those files.

    I'll look into the premissions thing next.

    Eddie

  9. jyotim
    Member
    Posted 2 years ago #

    Hi,

    I am absolutely new to wordpress and just recently installed a blog. I was trying to change General Settings (last tab in dashboard) and it gives options to change the url to something else. I typed in the url of my old blog (in both fields) and now when I try to access my wordpress installation it says error 404 - Page Not Found. How do I fix this? PLZ help !!
    Thanks

  10. webmaster-eddie
    Member
    Posted 2 years ago #

    ERROR SOLVED for me

    I am running a dedicated server with Debian Squeeze and couldn't get any wordpress install to work. Any page that had /wp-admin/ in the url did not work - it either showed a blank page or gave an error 500 or 400 usually message depending on the type of php file it was using - that is whether the web site was setup as FastCGI or mod_php ...

    I inally solved the problem by accident - removing suhosin from my server.

    Suhosin is included by default with Debian 5 and 6 . The latest up^grade to php - 5.3.9.1 - removes suhosin. Most of suhosin has been moved to the core. Upgrading php to 5.3.8 will force you to upgrade mysql to 5.5 - which is better, but may have a problem with SSL connections.

    So, this solved my problem - removong suhosin from my debian squeeze 64bit server.

    Eddie

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.