WordPress.org

Ready to get started?Download WordPress

Forums

MAJOR compatibility PROBLEMS with WordPress and bluehost (10 posts)

  1. europeanvisualarts
    Member
    Posted 6 years ago #

    Hello everyone.
    Are WordPress 2.3x and Bluehost NOT COMPATIBLE any more? They just won't work together for me.
    I use manual installation of the latest WordPress 2.3.2
    Problem 1: Although I have the correct .mo file uploaded, all I get is English. No localization
    Problem 2: No email notifications are sent from wordpress what soever. No notifications for new members (neither to their email nor to mine), not for new comments or new posts or drafts or subscriptions to posts or anything. Not even for a successful installation.
    This is my configuration:

    define('DB_NAME', 'base_xxxxx'); // The name of the database
    define('DB_USER', 'user_xxx'); // Your MySQL username
    define('DB_PASSWORD', 'password_xxx'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value
    define('DB_CHARSET', 'utf8');
    define('DB_COLLATE', 'utf8_general_ci');
    
    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!
    
    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-content/languages.
    // For example, install de.mo to wp-content/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', 'el');

    About problem 1: Even in older versions of WordPress I do NOT get my .mo files read. I tried using the fix provided HERE but did NOT work for me.
    About problem 2: Up until wordpress 2.2 I would get email notifications, but they would be sent by [email]aenaonin@box291.bluehost.com[/email] instead my blog's name. Of course I did not like my members to be notified by Bluehost instead of me but it was something. You can try registering at:

    I do run WordPress on other servres as well and it works fine. No problems at all.

    Do others have the same problems or is it just me? Why is this happening? It is very inconvenient.
    Any kind of help would be GREATLY appreciated. I have tried everything: new installs, fantastico installs, on the root, on subdomains, etc.... :confused:
    Thank you in advance, Michael

  2. Meyithi
    Member
    Posted 6 years ago #

    Email notifications broke for me with Bluehost too, but apart from that everything else is fine for me (manual install).

  3. europeanvisualarts
    Member
    Posted 6 years ago #

    So what can we do about this?
    I also posted for help in bluehost HERE

  4. Chris_K
    Member
    Posted 6 years ago #

    Did you see all theses other Bluehost posts here in the forums? Might be worth checking some out:
    http://wordpress.org/tags/bluehost

  5. europeanvisualarts
    Member
    Posted 6 years ago #

    I have checked quite a few with no luck so far.
    I keep looking

  6. europeanvisualarts
    Member
    Posted 6 years ago #

    I found nothing similar ro any solutions to my problems.
    I have to rely on your efforts and answers here.
    Any suggestions are always wellcomed

  7. lemon24
    Member
    Posted 6 years ago #

    Similar problem with email after updating to 2.3. With Version 2.3 it became necessary to create a wordpress@domain.com address in Bluehost in order for mail to be handled correctly. In my case, setting up a 'wordpress' email user resolved the problem.

  8. europeanvisualarts
    Member
    Posted 6 years ago #

    @lemon24:
    I manage to solve the problem the same way.
    Still... I do not like the idea of having the wordpress@domain.com address.
    So I found this plugin (http://wordpress.org/extend/plugins/set-email-from-address/) thinking it would help.
    Unfortunately I get errors after activating it that WILL NOT go away even if deactivated. And I cannot get in touch with its writer. Any ideas?

  9. charlesgan
    Member
    Posted 6 years ago #

    just remember that i have to switch off the bluehost fastcgi for my wordpress at http://www.bluehostreview.org/ to work correctly. I had it ON when they introduce this new fastcgi feature. But after few days using it, i do realise it caused some error to wp-admin and also the blog webpage itself.

    if your installation failed or upgrade failed, you need to check on your plugin files as well. Try disable all plugin by rename the /plugin folder and see whether you can load up the blog. USually this works for me when wordpress upgrade causes problem.

  10. BernardBorealis
    Member
    Posted 6 years ago #

    2.3.x still works well on Bluehost. I have a 2.3.3 installation doing this.

    For email, I found this information from another WordPress member useful. I tried to find his post to link it here, but couldn't so I'll just quote him and give him credit:

    "1.set up a completely new email address (i picked notifications@mydomain.com) - don't use wordpress@yourdomain.com

    2. then install this plug-in:

    wp-mail-smtp

    3. in the plug-in options tab set the options to:
    send mail using SMTP,
    send the mail using your new email address,
    fill in the SMTP host, username and password that your host gave you when you set up the new email address,
    YES, use smtp authentication

    4. Send yourself a test mail using the plugin to make sure it works.

    By doing all this you are bypassing php mailscripts altogether and you don't have to rely on your host having them working.

    It worked for me, I tested commenting on the blog and it came through immediately. When I turn this plugin off and try it I'm STILL not getting email notifications.

    Hope this helps, good luck everyone."

Topic Closed

This topic has been closed to new replies.

About this Topic