WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
Major bug in NGINX configuration code leads to 404 on all pages (6 posts)

  1. xl32
    Member
    Posted 1 year ago #

    We use W3TC on our site. After update to 0.9.2.8 and NGINX config reload we faced major bug: every page returned 404 error.

    Here are original lines to disable static file rewrite for missed files:

    if (-f "$document_root/wp-content/cache/page_enhanced/$http_host/$request_uri/_index.html$w3tc_enc") {
    set $w3tc_rewrite 0;
    }

    Here are my fixed lines:

    if (-f "$document_root/wp-content/cache/page_enhanced/$http_host/$request_uri/_index.html$w3tc_enc") {
    set $w3tc_rewrite 0;
    }

    Please implenment in bugfixed version.
    Thank you for a great plugin!

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. nickaster
    Member
    Posted 1 year ago #

    That's interesting...

    Has anyone responded to you? I'm not experienced to start tinkering with this, especially since my 404 problem is not on all pages, only a few random pages once in a while.

    Coincidentally (?) I am also experiencing a rash of "missed schedule" posts which leads me to believe this may have something do with server settings than the plugin itself.

  3. xl32
    Member
    Posted 1 year ago #

    nickaster, nope, you can see, author keeps silence.
    This bug is important as it forces to rewrite request to static file if file does not exist.

    Originally, it should check if file does not exist and disable this rewrite rule, falling back to normal index.php processing. In this buggy version, it checks if prerendered file exists and then disable rewrite.

    I simply negated this rule and everything works like a charm.
    Doesn't it looks like your behaviour? Just clean your cache and if you will get more 404s with new NGINX config installed (obtained from "Install" section, this fix is for you).

  4. nickaster
    Member
    Posted 1 year ago #

    hm.... i don't think this is my problem. i only get a few 404s, randomly. Then I clear the cache and everything is fine. Then a few hours later, some random 404s come back.

    I'd be eager to hear what the plugin guys say!

  5. Pothi
    Member
    Posted 1 year ago #

    This topic has been discussed already here in more detail. As per the plugin author, it will be fixed in the next version.

  6. xl32
    Member
    Posted 1 year ago #

    Great news. But is it true, the major bug (as it leads to full site downtime due to 404 errors) is not fixed for more than month while ready-to-use patch available?

    Can I ask author "why"?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic