WordPress.org

Ready to get started?Download WordPress

Forums

Itek
[resolved] Main Product Images are Stretched and distorted (4 posts)

  1. rullywowr
    Member
    Posted 2 months ago #

    Hello,

    Great theme, and really love the flow and feel of it. Everything is pretty good but I am having a really tough time getting my "main product image" to not be all bloated and stretched out. All the rest of the images look great! My site is
    http://www.rullywow.com

    I have set my WooCommerce/Settings/Product image size to the following:

    Catalog: 472x472 px
    Single Product: 500 x 500 px
    Product Thumbnails: 250x250 px

    In Settings/Media I have my thumbnail size set at 200px x 200px. Yes, I am "regenerating thumbnails" but still the main product image looks all wacked out.

    What am I doing incorrectly? Thanks in advance

  2. Zulfikar Nore
    Member
    Theme Author

    Posted 2 months ago #

    As you have changed the image sizes you'll need to regenerate the images as WordPress does not apply new image sizes to old/pre uploaded images.

    Try using the Regenerate Thumbnails plugin to see if that resolve the issue for you.

    Regards,
    Zulf

  3. rullywowr
    Member
    Posted 2 months ago #

    Hi Zulfikar,

    I tried regenerating thumbnails numerous times. It is strange because the product image is much wider than it should be, but if you download the image it turns out fine (500px 500px)

    What else can I do? Everything else seems to be working pretty well, just the main product images are bloated.

    Are there default Settings you have for Catalog/Single Product/Product Thumbnails and the Settings->Media thumbnail size?

  4. rullywowr
    Member
    Posted 2 months ago #

    I solved my issue...

    I had to change "customwoo.css" line here:
    .woocommerce-page div.product div.images img {
    max-height: 452px; height: auto; margin-top: 32px; }

    I changed the "max-height" to "auto" and everything is at least square now and looks good. Not sure why this wasn't taking care of itself but this is the fix for me.

Reply

You must log in to post.

About this Theme

About this Topic