WordPress.org

Ready to get started?Download WordPress

Forums

Main page works fine, but individual pages don't (5 posts)

  1. mkcom
    Member
    Posted 6 years ago #

    I just installed WordPress 2.1.3 at
    http://www.aishwaryaraibachchan.net/

    And the main page seems to load just fine. I've been able to change the theme, adjust the header and footer, etc. But when you click on any individual post or page, I get a 404 error:

    Not Found
    The requested URL /2007/04/19/test/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/1.3.33 Server at http://www.aishwaryaraibachchan.net Port 80

    If it helps, this was installed on a WordPress Linux hosting package. When I create new posts, they display on the main page without issue. Any idea what the problem could be?

  2. t0v3
    Member
    Posted 6 years ago #

    Its a problem with using permalinks. Change them to default and it should work fine. If you want "pretty" links you'll need to make a htaccess file

  3. lgonzale
    Member
    Posted 6 years ago #

    tov3...I was having similar issue..and your fix worked...could you point me in the right direction as to how to have 'pretty" links...thanks so much!!

  4. moshu
    Member
    Posted 6 years ago #

  5. RadioNerd
    Member
    Posted 6 years ago #

    I am also having this problem, all links result in a 404. I have a clean install of WP 2.2. Did the touch .htaccess command and did a chmod 666. The second I change from "Default" to "Date and name based" none of my links work. The links do appear as I want them, it's not sending them off to some weird directory or anything. I have all of the WP in the main directory of the website and the htaccess file is also in the main directory.

    This is what my htaccess file looks like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    In my apache config file, I have this:

    LoadModule rewrite_module libexec/httpd/mod_rewrite.so
    AddModule mod_rewrite.c
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteCond %{REQUEST_METHOD} ^TRACE
    RewriteRule .* - [F]
    </IfModule>

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags