WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Main page works, but all other WP pages 404-ing (5 posts)

  1. tedgoas
    Member
    Posted 7 years ago #

    My main page works, but all of my WP posts and pages return a 404 error and 'Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.' This happens for all posts, feed, and pages (such as 'About')

    Other threads suggest checking out mod_rewrite and AllowOverride with my host, and my host claims it has not changed anything lately.

    I was fiddling with my permissions a few days ago, might it have something to do with that? My wp-config is set to 744.

    URL in question - http://www.tedgoas.com (click on posts)

  2. tedgoas
    Member
    Posted 7 years ago #

    I should probably add that my permalinks were working for a while before this happened. My .htaccess file (644) is as follows

    RemoveHandler .html .htm
    AddType application/x-httpd-php .php .htm .html .asp

  3. Chris_K
    Member
    Posted 7 years ago #

    that .htaccess won't do anything for you except default permalinks.

    If you were using Pretty Permalinks, then hie thee back to Options -> Permalinks and set 'em again.

  4. tedgoas
    Member
    Posted 7 years ago #

    HandySolo, that makes total sense. I don't understand how it worked in the first place. But thank you for the help. I followed your instructions and all seems to be well again!

    Thank you for the response!

    -Ted

  5. TotusUnus
    Member
    Posted 6 years ago #

    I had the same issue on http://totusunus.com/ I have now solved the issue.
    I went to permalinks, deleted what was in the custom category and then selected another choice and saved. Then went back to permalinks and pasted back in what was originally there, updated again. Bingo all ok 
    Originally there was /%category%/%postname%/

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags