WordPress.org

Ready to get started?Download WordPress

Forums

Strictly Auto Tags
[resolved] Main navigation in /tag/ disappears (2 posts)

  1. whiteorb
    Member
    Posted 3 years ago #

    When I have strictly auto tags active it causes the main navigation on the /tags/ page to disappear entirely. Any idea what would cause that to occur?

    <div id="access" role="navigation">
                    <div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">
              Skip to content          </a></div>
                    <div class="menu-header"><ul id="menu-main-navigation" class="menu"></ul></div>        <div style="position:relative; height:0; top:-30px; left:775px; width:151px; height:0px;">
              <form role="search" method="get" id="searchform" action="/">
    	<label class="screen-reader-text" for="s">Search for:</label>
        <input type="text" onfocus="if (this.value == 'Search')
        {this.value = '';}" onblur="if (this.value == '')
        {this.value = 'Search';}" id="s" name="s" value="Search" class="search-form round">
        <input type="hidden" id="searchsubmit">
        </form>        </div>
          </div>

    Otherwise it looks like this

    <div id="access" role="navigation">
                    <div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">
              Skip to content          </a></div>
                    <div class="menu-header"><ul id="menu-main-navigation" class="menu"><li id="menu-item-4238" class="menu-item menu-item-type-post_type menu-item-object-page current-menu-item page_item page-item-27 current_page_item menu-item-4238"><a title="OpenEye Home" href="http://www.openeye.net/">Home</a></li>
    <li id="menu-item-4168" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-4168"><a title="OpenEye Products & Services" href="http://www.openeye.net/products/">Products</a></li>
    <li id="menu-item-23" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23"><a title="OpenEye Support" href="http://www.openeye.net/support/">Support</a></li>
    <li id="menu-item-22" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-22"><a title="OpenEye News & Events" href="http://www.openeye.net/news-events/">News & Events</a></li>
    <li id="menu-item-26" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26"><a title="About OpenEye" href="http://www.openeye.net/about-us/">About OpenEye</a></li>
    <li id="menu-item-21" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-21"><a title="Contact OpenEye" href="http://www.openeye.net/contact-us/">Contact Us</a></li>
    <li id="menu-item-9884" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-9884"><a title="OpenEye Frequently Asked Questions" href="http://faq.openeye.net/">FAQ</a></li>
    </ul></div>        <div style="position:relative; height:0; top:-30px; left:775px; width:151px; height:0px;">
              <form role="search" method="get" id="searchform" action="/">
    	<label class="screen-reader-text" for="s">Search for:</label>
        <input type="text" onfocus="if (this.value == 'Search')
        {this.value = '';}" onblur="if (this.value == '')
        {this.value = 'Search';}" id="s" name="s" value="Search" class="search-form round">
        <input type="hidden" id="searchsubmit">
        </form>        </div>
          </div>
  2. Strictly Software
    Member
    Plugin Author

    Posted 2 years ago #

    Sorry I have no idea why my plugin would interfere in the layout of core wordpress code. This is the first time I have heard of this weird problem.

    Maybe you have a theme that has overwritten one of my functions or vice-versa. Try another theme to rule that out.

    Have you tried all the obvious debugging methods e.g

    -de-activate all plugins and try mine on it's own
    -uninstall all plugins and try mine on it's own

    If you have ruled out other plugins try another theme, de-activate javascript, images, cookies etc and just rule out all the possibilities.

    Are you getting PHP errors, warnings or Javascript errors?

    If you are still having problems turn on DEBUG, add some echo's and trace the problem down to the function causing it but I really doubt my plugin would have any effect on the layout of a site as it only hooks into the POST article action and modifies an articles content before it is saved to the database and I don't do anything unrelated to the admin page or when the article is spat back out to be displayed.,

    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic