WordPress.org

Ready to get started?Download WordPress

Forums

Main menu not working (8 posts)

  1. krisdysert
    Member
    Posted 1 year ago #

    I created this site yesterday, and have disabled plug-ins. I am new to WP, so this may be basic.

    I have created a couple of pages, which have automatically appeared in the header menu. The links don't work - why?

    onesixonestl.com

  2. tomontoast
    Member
    Posted 1 year ago #

    Your permalink structure is not working probably due to a missing .htaccess file see http://codex.wordpress.org/Using_Permalinks

  3. rfair404
    Member
    Posted 1 year ago #

    to follow up on tomontoast's comment, in the Admin go to Settings > Permalinks and set them to the default. See if the links work then? If not can you post the url's to your homepage and the broken links?

  4. krisdysert
    Member
    Posted 1 year ago #

    Even if I paste in the link, the page is not there.

    Edit Page Add New
    Enter title here
    Permalink: http://www.onesixonestl.com/about/ ‎Edit View Page

    It acts as if it created the page there, but it didn't. Where is the page?

    Also, if I "Preview" the page, I get a 404.

  5. krisdysert
    Member
    Posted 1 year ago #

    I changed the permalinks back to default and can now find the page. I guess it says it created it with a post name, but didn't?

  6. krisdysert
    Member
    Posted 1 year ago #

    One more question: if you visit

    http://www.onesixonestl.com/?page_id=19

    and click the picture, you get another 404. Ideas?

    Thanks all, I appreciate the quick help!

  7. tomontoast
    Member
    Posted 1 year ago #

    You need to edit the picture link on that page to get rid of the incorrect link which still assumes permalinks.

  8. krisdysert
    Member
    Posted 1 year ago #

    Gotcha - thanks again!

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.