WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] main index page not displaying content (6 posts)

  1. phillyb
    Member
    Posted 1 year ago #

    using wordpress 3.4.2
    i'm using the theme vintage camera
    up until around an hour ago (5pm eastern), my home page (index.php site url - http://www.phillybhatesme.com) was displaying fine.
    now it is not showing the content beneath the navbar and the footer.

    in the theme editor, the main index page looks like this...

    <?php
    /**
     * The main template file.
     *
     * This is the most generic template file in a WordPress theme
     * and one of the two required files for a theme (the other being style.css).
     * It is used to display a page when nothing more specific matches a query.
     * E.g., it puts together the home page when no home.php file exists.
     * Learn more: http://codex.wordpress.org/Template_Hierarchy
     *
     * @package Vintage Camera
     * @since Vintage Camera 1.0
     */
    
    get_header(); ?>
    
    		<div id="primary" class="site-content">
    			<div id="content" role="main">
    			<?php if ( have_posts() ) : ?>
    
    				<?php /* Start the Loop */ ?>
    
    			<?php elseif ( current_user_can( 'edit_posts' ) ) : ?>
    
    				<article id="post-0" class="post no-results not-found">
    
    <p style="font-size:x-large;"><font face="fantasy, serif">
    spread the hate. check out the <a href="http://www.phillybhatesme.com/map/"><FONT COLOR="0a14dd">map!</FONT></a></br></br>
    get a decal within the us...<a href="http://www.phillybhatesme.com/contact/"><FONT COLOR="0a14dd">phill out the contact phorm!</FONT></a></br></br>
    outside of the united states? <a href="http://www.phillybhatesme.com/internationalcontactphorm/"><FONT COLOR="0a14dd">use the international contact phorm!</FONT></a></br></br>
    see the decals in action...visit the <a href="http://www.phillybhatesme.com/gallery/"><FONT COLOR="0a14dd">gallery!</FONT></a></br></br>
    donors receive extra decals! <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=WRX9E9GXS9BHN"><FONT COLOR="0a14dd">donate</FONT></a> to the neverending stamp and envelope fund!</font></p></font>
    
    				<div class="entry-content">
    					</div><!-- .entry-content -->
    				</article><!-- #post-0 -->
    
    			<?php endif; ?>
    
    			</div><!-- #content -->
    
    		</div><!-- #primary .site-content -->
    <?php get_footer(); ?>

    as you can see, there should be some content.
    i tried using the original code which came with the theme, to no avail.
    i also reverted the stylesheet back to it's original content to no avail.

    the other pages on the site contain a pale colored "background" that contains the content of that page.
    as you can see on http://phillybhatesme.com, that "background" isn't there.

    please help

  2. phillyb
    Member
    Posted 1 year ago #

    this is what it should look like - http://i.imgur.com/bZ0v9.png

    this is what it looks like - http://i.imgur.com/c1oB2.png

  3. esmi
    Forum Moderator
    Posted 1 year ago #

    Try re-uploading a fresh copy of the theme's unpacked zip file to wp-content/themes using FTP.

  4. phillyb
    Member
    Posted 1 year ago #

    i don't have ftp access, but would uninstalling the theme and re-installing the zip accomplish the same thing you're suggesting?

  5. phillyb
    Member
    Posted 1 year ago #

    that didn't work it's displaying in firefox (probably cause it's cached) but not in safari or chrome.
    i have contact form 7 installed and that was the only other thing i was fiddling with when i noticed this issue.

  6. phillyb
    Member
    Posted 1 year ago #

    changed the code to this...

    <?php
    get_header(); ?>
    
    		<div id="primary" class="site-content">
    			<div id="content" role="main">
    
    <article id="post-0" class="post no-results not-found">
    
    <p style="font-size:x-large;"><font face="fantasy, serif">
    spread the hate. check out the <a href="http://www.phillybhatesme.com/map/"><FONT COLOR="0a14dd">map!</FONT></a></br></br>
    get a decal within the us...<a href="http://www.phillybhatesme.com/contact/"><FONT COLOR="0a14dd">phill out the contact phorm!</FONT></a></br></br>
    outside of the united states? <a href="http://www.phillybhatesme.com/internationalcontactphorm/"><FONT COLOR="0a14dd">use the international contact phorm!</FONT></a></br></br>
    see the decals in action...visit the <a href="http://www.phillybhatesme.com/gallery/"><FONT COLOR="0a14dd">gallery!</FONT></a></br></br>
    donors receive extra decals! <a href="https://www.paypal.com/cgi-bin/webscr?cmd=_s-xclick&hosted_button_id=WRX9E9GXS9BHN"><FONT COLOR="0a14dd">donate</FONT></a> to the neverending stamp and envelope fund!</font></p></font>
    
    <div class="entry-content">
    					</div><!-- .entry-content -->
    </article><!-- #post-0 -->
    			</div><!-- #content -->
    
    		</div><!-- #primary .site-content -->
    <?php get_footer(); ?>

    and i'm back up and running

Topic Closed

This topic has been closed to new replies.

About this Topic