WordPress.org

Ready to get started?Download WordPress

Forums

Main blog images & video missing (4 posts)

  1. mdfilms
    Member
    Posted 2 years ago #

    I have no idea but all my images and videos are not showing on the main blog page. If you click "read more" everything is still within the post but not displaying on the main post. I have checked all the settings but cant find anything wrong

    Any ideas ? I cant figure this out

    Heres a link http://www.mdfilms.net/category/blog/

    Thanks

  2. Ryan Imel
    Member
    Posted 2 years ago #

    It appears your theme is using the_excerpt on that page, whereas your post pages themselves are using the_content. the_except defaults to only displaying text and not images or video, while the_content will display everything (no matter the content) up until the more tag shows up.

    Are you comfortable modifying theme files? If so it should be a simple change to make, otherwise you will need to consult with the theme developer or work with someone else who knows.

    Read more about the_excerpt: http://codex.wordpress.org/Function_Reference/the_excerpt
    Read more about the_content: http://codex.wordpress.org/Function_Reference/the_content

  3. mdfilms
    Member
    Posted 2 years ago #

    Figured it out

    In archive.php, replace lines 41 and 42:

    <?php the_excerpt(); ?>
    <?php more_link(); ?>
    with this:

    <?php the_content(); ?>

  4. Ryan Imel
    Member
    Posted 2 years ago #

    Awesome, glad you were able to solve it. Feel free to mark the thread resolved :)

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.