WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
Mailchimp's Social and WP-Supercache (9 posts)

  1. Spegis
    Member
    Posted 2 years ago #

    I just installed the new plug in Social, and I really like it... but when I have WP-Supercache and Social running at the same time, I get the following error on any site page load:

    Warning: require(/home/content/10/XXXXXXX/html/wp-content/plugins/wp-super-cache/plugins/lib/social/interface/service.php) [function.require]: failed to open stream: No such file or directory in /home/content/10/XXXXXXX/html/wp-content/plugins/social/social.php on line 392
    
    Fatal error: require() [function.require]: Failed opening required '/home/content/10/XXXXXXX/html/wp-content/plugins/wp-super-cache/plugins/lib/social/interface/service.php' (include_path='.;C:\php5\pear') in /home/content/10/5874810/html/wp-content/plugins/social/social.php on line 392

    This is on a self hosted Godaddy linux instal (most recent php and SQL versions) of the most recent WP base. Has anyone else seen this?

  2. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    Looks like a problem in the social plugin. Edit the file wp-content/plugins/social/social.php on line 392 and make sure it uses ABSPATH in the include() statement.

  3. Spegis
    Member
    Posted 2 years ago #

    Thank you for the reply... I'm afraid I'm a bit to novice to know the way to fix this. I assume that ABSPATH is setting an absolute path.... I'm not sure where on line 392 to place this.

    Could you give me a few more hints?

    // Load Twitter/Facebook
    		require SOCIAL_PATH . 'lib/social/interface/service.php';
    		require SOCIAL_PATH . 'lib/social/helper.php';
    		require SOCIAL_PATH . 'lib/social/service.php';
    		require SOCIAL_PATH . 'social-facebook.php';
    		require SOCIAL_PATH . 'social-twitter.php';

    Thanks!

  4. Spegis
    Member
    Posted 2 years ago #

    Am I supposed to replace SOCIAL_PATH with ABSPATH?

  5. Donncha O Caoimh
    Member
    Plugin Author

    Posted 2 years ago #

    You could try printing/wp_mail/error_log the SOCIAL_PATH constant to see what it contains there. I suspect there's a bug in their plugin somewhere and that constant won't be set.

    Otherwise, try replacing SOCIAL_PATH with:

    ABSPATH . "wp-content/plugins/social/"

    Leave the dot that's already on those lines there.

  6. Spegis
    Member
    Posted 2 years ago #

    OK, so now the site loads again, but I received a similar error on line 1662:

    Warning: require(/home/content/10/XXXXXXX/html/wp-content/plugins/wp-super-cache/plugins/lib/social/walker/comment.php) [function.require]: failed to open stream: No such file or directory in /home/content/10/XXXXXXX/html/wp-content/plugins/social/social.php on line 1662

    Fatal error: require() [function.require]: Failed opening required '/home/content/10/XXXXXXX/html/wp-content/plugins/wp-super-cache/plugins/lib/social/walker/comment.php' (include_path='.;C:\php5\pear') in /home/content/10/XXXXXXX/html/wp-content/plugins/social/social.php on line 1662

    Making the same change gives back the WordPress commenting ability, but the "Social" does not load the Facebook and twitter images to click on.

    Can't seem to got the feature back. If you have an other thoughts that would be great, but like you said, it's a bug in the plug in as far as WP-Super Cache is concerned.

  7. mc_nate
    Member
    Posted 2 years ago #

    Yo dudes!

    Sorry to butt in here, we actually have a separate discussion group set up solely for that Social Plugin, here:

    http://wordpress.org/tags/social?forum_id=10

    That might help it get in front of the right set of eyeballs, quicker!

    But, out of morbid curiosity, which version of Super Cache are you running? I was able to get SuperCache 0.9.9.9 up and running with the Social plugin at the same time:

    http://screencast.com/t/UBfgPIOR2

  8. Spegis
    Member
    Posted 2 years ago #

    Mc_nate, thank you for your feedback, this post already shows up at the link you provided. To answer your question, I have updated the tags for this post to include the versions of Social and WP Super Cache I am using. 1.0 and 0.9.9.9 respectively.

    Any tips on how what your WP Super Cache settings that I may want to alter on my end?

    Thanks again.

  9. mc_nate
    Member
    Posted 2 years ago #

    Ah, my fault!

    As far as a special setup is concerned, I didn't really do anything out of the ordinary. I didn't have Super Cache installed previously, so I installed that one first and then made the edit to my config.php file (as instructed to allow for caching). Then I installed the Social Plugin, as well, straight from the WordPress "search plugins" function.

    After that, I set up my social networks through Facebook and Twitter and everything went off without a hitch.

    Although, for the sake of full disclosure, I've only got a couple of different plugins running currently: Super Cache 0.9.9.9, Social 1.0, and MailChimp Signup 1.2.4. All other plugins are disabled.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic