WordPress.org

Ready to get started?Download WordPress

Forums

Genesis eNews Extended
[resolved] MailChimp integration = double the work? (6 posts)

  1. josiedds
    Member
    Posted 6 months ago #

    So I have installed this great plugin and have entered my mailchimp code and it works perfectly! However, I feel like entering the email twice is double the work for my subscribers.

    For example, if you go to my site: http://www.sharingmom.com
    in the header is the plugin "opt in" form. Once you enter your email, it takes you to the mail chimp subscriber form and one would have to re-enter their info.

    Is there a way to remove the email field from the genesis plug in and just have the button for people to click on (and then it would direct them to the mailchimp form?)

    Or do I uninstall the genesis plug in and just use a click through button image instead?

    I have tried to figure this out, but I am a novice so any input would be great.... please be very specific...consider me dumb... lol

    https://wordpress.org/plugins/genesis-enews-extended/

  2. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 6 months ago #

    Howdy!

    This is because there are a couple of issues with your setup. The MailChimp link you added in the form action field is the link to the sign-up form, not the link for the MailChimp processor.

    For the Form Action field setting, try this instead: http://sharingmom.us7.list-manage.com/subscribe/post?u=9374a04505a284c63ebd3d156&id=11d5da4dc0

    Then, in the E-Mail Field Name setting, use this: EMAIL

    That way, the e-mail address will be "tagged" in the way that MailChimp understands and submitted to the place they're expecting it.

    Cheers!

  3. josiedds
    Member
    Posted 6 months ago #

    Thanks for getting back to me. I tried what you suggested but it did the same thing...only this time, it directed me to the mail chimp sign-up form with error alerts.

    Please advise. I'm going to inactivate the widget for now until we can figure it out.

  4. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 6 months ago #

    Okay, can you try it again? I can't test it further on your site with it inactive to see what may have been copied over that needs to be adjusted.

    I added those settings to the widget visible at http://test.bk.cx/3.8-branch/ (right-side sidebar) and it works. I'll leave it up so you can try it.

    The Form Action field should be http://sharingmom.us7.list-manage.com/subscribe/post?u=9374a04505a284c63ebd3d156&id=11d5da4dc0 and the E-Mail Field Name setting should be EMAIL.

    Here's a screenshot of the settings, with the form action cutoff due to length: https://cloudup.com/cEtqbWn5H9D

    If you want to work through it yourself, there's a video and a link to written instructions at http://www.brandonkraft.com/contrib/plugins/genesis-enews-extended/install/#mailchimp .

  5. iwritten
    Member
    Posted 6 months ago #

    Hi Brandon,

    Thanks for your support. I had the same issue and came across this post.

    The problem for me was that I tried to use an existing list which contained a survey in addition to the basic EMAIL, FNAME AND LNAME.

    To resolve the issue, I created a new list that only had these three fields. Copying the form action url from the MailChimp signup forms/embedded forms menu for the list I had the same results as you did in your test: http://test.bk.cx/3.8-branch/

    I hope this helps.

  6. Brandon Kraft
    Happiness Engineer
    Plugin Author

    Posted 6 months ago #

    Thanks for posting that. That's right—if your list requires more information than what the eNews form has, it'll fail too.

    Cheers!

Reply

You must log in to post.

About this Plugin

About this Topic