WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] MailChimp Form Function on Home page vs. Other Pages (8 posts)

  1. joatblog1
    Member
    Posted 2 years ago #

    Hi There!

    I'm using the "MailChimp" plugin, and was testing out the form by signing myself up.

    I noticed it doesn't work on the home page. I click the submit button (it does animate upon my clicking), but then nothing occurs. Then the button is no longer clickable after that (does not animate when clicking).

    The form works perfectly on every other page on my blog! When I click, the page quickly refreshes and the message "Success, you've been signed up! Please look for our confirmation email!" appears within the form.

    Why isn't it working on my home page??
    Thanks in advance for the help! :)

  2. joatblog1
    Member
    Posted 2 years ago #

    Anybody?

  3. mc_nate
    Member
    Posted 2 years ago #

    Sorry, I've been out of the 'ol office for a few days.

    Can you post a link to your page so we can check it out?

  4. joatblog1
    Member
    Posted 2 years ago #

    Hey mc_nate! Glad to see ya! :)

    My site is joatblog.com

  5. jason_lane
    Member
    Posted 2 years ago #

    joatblog (Kenia?), it seemed to work fine for me. I got the success message on the screen, and received the confirmation email. What browser were you using? I was using Chrome on OSX.

    Cool blog concept, BTW!

  6. mc_nate
    Member
    Posted 2 years ago #

    Hey again!

    Like my man Jason_Lane reported, I'm able to submit the form with information and have it send me the confirmation email:
    http://cl.ly/0D2o3r2J3B1I433a3Q3J

    Success message:
    http://cl.ly/1h2H0C1v1k152X1K043e

    What we might recommend doing is switching to a different browser to see if it's somehow related to a rendering issue or conflict on that homepage.

    Let us know if we can assist in any other way!

    Cheers

  7. joatblog1
    Member
    Posted 2 years ago #

    Jason and Nate: THANK YOU for looking into this for me. I truly appreciate you two taking the time out to check it out.

    It works!! (It's still not working for me on my two computers (using both IE8 and Firefox), but I had a friend try it out too and it worked for him on Firefox. It also worked fine on my smartphone.)
    False alarm. Phew!!

    The weird thing is, i tried clearing cookies & history out of both my browsers, but it still didn't work so I thought it was a real issue and not just my computer.

    Jason, Thanks! (Yes, this is Kenia) :) I'm glad you like my blog concept. :-D I'm trying to finalize these last few things so I can launch it this week (i.e. tell people about it).

  8. jason_lane
    Member
    Posted 2 years ago #

    Kenia, it could be a Javascript issue, and it could be that one of your Firefox plugins is somehow conflicting with the Mailchimp form. You could try using Firebug to try to debug the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic