WordPress.org

Ready to get started?Download WordPress

Forums

MailChimp List Subscribe Form
[resolved] Mailchimp error (6 posts)

  1. rpwilso
    Member
    Posted 1 year ago #

    Sends up a message that ">>You must fill in ." in red.
    The only thing requested to fill in is the e-mail address, and it is accurate. It worked with WordPress 3.5, but not with 3.5.1.

    http://wordpress.org/extend/plugins/mailchimp/

  2. mc_tak
    Member
    Posted 1 year ago #

    Hey rpwilso,

    Sorry to hear about the issues that you're having with the plugin. On my end, I've been able to use the plugin without issue since upgrading to 3.5.1, so the plugin should be compatible with this most recent version of WordPress.

    So that we could take a closer look, do you have a link to the site that has the active form, which throws the error message?

    Also, do you have any required elements in your MailChimp list? For example, while your form may only be showing the "Email Address" field, do you have any other fields in your MailChimp list, that might be marked as required? If so, would you be able to try disabling all additional 'required' fields inside of your MailChimp account, and trying again?

    We look forward to hearing back!

    -tk

  3. rpwilso
    Member
    Posted 1 year ago #

    Hi,
    Sorry for the delay getting back. To the best of my knowledge, the only required field is the e-mail address. I cannot find anywhere to tell it what to require and what not to. Here is what I see at the bottom of the settings page:

    Merge Variables Included
    Name Tag Required? Include?
    Email Address EMAIL Y —
    First Name FNAME N
    Last Name LNAME N
    Contact Phone (optional) PNUMB N
    Interest Groups
    Error retrieving interest groups. Please re-import the list.

    And then the "Update subscribe forms setting" button. Nowhere (that I can find) is there an option to even make the first name, last name, etc. a required field. When I access settings from Mailchimp in the plugin menu, or the "Mailchimp setup" option from the Settings sidebar, both send me to the same page. you can see the signup issue here: vegetables

    Patrick

  4. mc_tak
    Member
    Posted 1 year ago #

    Hey Patrick,

    The Required setting will actually be setup inside of your MailChimp account, rather than from the WordPress side of things.

    To ensure whether you have any fields set to required on your list, login to your MailChimp account, then go to the Lists tab > Navigate to the list in question > click the gear/cog icon > Forms. From there, any required field should be indicated by a red asterisk.

    Once you've ensured that the email address field is the only required field, log in back to your WP admin area, go to your MailChimp plugin settings, then click the 'update list' button.

    If you're still unable to submit the form as expected, we'd recommend going to your plugin settings, then clicking the "logout" button at the top. Then, log back in to your account, reconnect your list, and try signing up again.

    We look forward to hearing back!

    -tk

  5. rpwilso
    Member
    Posted 1 year ago #

    All righty. That worked. Thank you for all your help. I'll go back and change this to "working" from "broken", too. I had no idea about the second part of the setup (within our MailChimp account) as I look after the website side of things, and another person looks after the newsletter side.

    Thanks again.
    Patrick

  6. mc_tak
    Member
    Posted 1 year ago #

    Glad to hear! Let us know if you have anymore questions. :)

    -tk

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.