WordPress.org

Ready to get started?Download WordPress

Forums

Postie
Mail Server Menu Save Changes Redirect To /wp-admin/options.php (10 posts)

  1. myedream
    Member
    Posted 1 year ago #

    Hi Gang's

    Under Mail Server menu, after putting all the mail setting figures, when I clicked the "Save Change" the wordpress redirect to:

    domain.com/wp-admin/options.php

    I am using default wordpress theme and only WP RSS To Post plugin...

    Any idea?

    http://wordpress.org/extend/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    This is the correct thing for the settings page to do. From the options.php file

    * This file is also the target of the forms in core and custom options pages
    * that use the Settings API. In this case it saves the new option values
    * and returns the user to their page of origin.

    Further down in the page it attempts to do a redirect to the referring page. Is it possible the referer isn't getting set correctly?

  3. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    fyi here is how wp gets the referer

    function wp_get_referer() {
    	$ref = '';
    	if ( ! empty( $_REQUEST['_wp_http_referer'] ) )
    		$ref = $_REQUEST['_wp_http_referer'];
    	else if ( ! empty( $_SERVER['HTTP_REFERER'] ) )
    		$ref = $_SERVER['HTTP_REFERER'];
    
    	if ( $ref !== $_SERVER['REQUEST_URI'] )
    		return $ref;
    	return false;
    }
  4. myedream
    Member
    Posted 1 year ago #

    I will check it out.

    Thank you!

  5. TrevorHook
    Member
    Posted 1 year ago #

    I'm also getting a similar problem.

    WordPress 3.4.2
    Postie 1.4.5

    When I attempt to save the mail server settings on a brand new install, I get 403 error messages for <domain name>/wp-admin/options.php

    I have an older Postie install on a sub-domain, setup a long time ago but updated to the current version for WordPress and Postie which is apparently working correctly but I haven't attempt to reset the mail server settings in the sub-domain installation because I don't want to break access.

  6. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Try accessing <domain name>/wp-admin/options.php directly. A 403 is a forbidden error, could mean permission issues.

  7. TrevorHook
    Member
    Posted 1 year ago #

    Hi

    Direct access to the /wp-admin/options.php page redirects me to the admin login page (I wasn't logged in when I manually entered the URL) and then on to the options.php page giving me the list of options.

    I don't know if you would expect to see any Postie relate settings in the output of options.php but there weren't any listed.

  8. TrevorHook
    Member
    Posted 1 year ago #

    I think my issue was a permissions issue, it's now been resolved by tech support at my web host.

    I'm waiting to hear back as to what the cause was and I'll post back here if I think it's a relevant to Postie in general.

  9. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for letting us know.

  10. TrevorHook
    Member
    Posted 1 year ago #

    I've heard back, they have disabled mod_sec for my entire account.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic