WordPress.org

Ready to get started?Download WordPress

Forums

Mail notifications not working, and BP makes the difference (5 posts)

  1. ecurtain
    Member
    Posted 4 years ago #

    Ok, I'm another WP/BP user who can't get mail notifications working. Hours of searching forums and the net haven't found a solution, so it's time to try the forums. Here are my specs:

    1. WordPress Version 2.9.2
    2. WordPress is installed in a directory
    3. It's in a subdirectory off the root: myhost.com/wordpress
    4. This was a fresh install, not an upgrate
    5. WordPress works fine until I activate BuddyPress. Then all mail notification fails. When I deactivate BuddyPress, mail is fine again.
    6. BuddyPress Version 1.2.1
    7. Also a clean install of BP
    8. Several other plugins installed, all but WP-Mail-SMTP have been deactivated. WP-Mail-SMTP is attempt to get this working via SMTP.
    9. Using Theme BuddyPress Default
    10. No modifications to the core files.
    11. No custom fuctions.
    12. Not running BBPress. (BP came with BBPress built in, but I deactivated it)
    13. There appear to be no errors in the server log file. (There were some caused by the deactivating-BP-without-changing-themes white screen of death.)
    14. My hosting company is HostMonster

    So, I can register new users but they don't get notification emails. When I use the "forgot my password" form, I get the message "The e-mail could not be sent.
    Possible reason: your host may have disabled the mail() function..."

    With BP deactivated, users get notification emails. Using the "forgot my password" form works fine and doesn't give an error.

    I've tried the SMTP approach with various plugins, email accounts set up on my server, and with gmail. My latest attempt uses an email account set up on my server and WP-Mail-SMTP with these settings:

      From email: wordpress@crimsoncurtain.com (a valid email account)

    • From Name: Oh God, Please make this work
    • Mailer: Send all WordPress emails via SMTP. (I also tried the PHP mail() option too - was getting desperate)
    • SMTP Options (as provided by my host company):
      SMPT Host: wordpress@crimsoncurtain.com
      SMTP Port: 26 , No encryption, SMTP authorization userid & password.
      (Also tried 26, 465 / SSL, TLS / No SMTP , etc)

    With BP disabled this sends a test email just fine. Activate BP and I get (messages reduced):
    ...
    The result was: bool(false)
    ... SMTP Error: The following SMTP Error: Data not accepted.myemail@hotmail.com
    ...

    array(13) {
    ["mailer_not_supported"]=> string(25) " mailer is not supported."
    ["provide_address"]=> string(55) "You must provide at least one mailer is not supported."
    ["execute"]=> string(19) "Could not execute: "
    ["instantiate"]=> string(36) "Could not instantiate mail function."
    ["authenticate"]=> string(35) "SMTP Error: Could not authenticate."
    ["from_failed"]=> string(35) "The following From address failed: "
    ["data_not_accepted"]=> string(30) "SMTP Error: Data not accepted."
    ["recipients_failed"]=> string(56) "SMTP Error: The following SMTP Error: Data not accepted."
    ["connect_host"]=> string(43) "SMTP Error: Could not connect to SMTP host."
    ["file_access"]=> string(23) "Could not access file: "
    ["file_open"]=> string(33) "File Error: Could not open file: "
    ["encoding"]=> string(18) "Unknown encoding: "
    ["signing"]=> string(15) "Signing Error: "
    }

    So, it really looks like BuddyPress is what's keeping mail from working, and I've run out of ideas to try.

    I'd love it if anyone has ideas on what the problem could be. Help! Any suggestions?

    Thanks,
    Phillip

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Are you using WP or WPMU?

    Have you tried http://buddypress.org/forums/

  3. ecurtain
    Member
    Posted 4 years ago #

    I'm using WP.

    I tried it with WPMU at first and had the same problem. I uninstalled everything and reinstalled WP, to eliminate the possibility that WP-MU might be the problem.

    Whoops, I think the BP forums would be a better place to post - thx.

  4. Joseph
    Member
    Posted 4 years ago #

    I have managed to fix this issue. Her's my fix for BuddyPress e-mail notifications problem.

  5. ecurtain
    Member
    Posted 4 years ago #

    I managed to fix the issue following a suggestion from ruthlessbookie...

    The mail-from plugin did the trick for me.

Topic Closed

This topic has been closed to new replies.

About this Topic