WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
[resolved] mail not delivered on same domain (localhost) as website (9 posts)

  1. kristonweb
    Member
    Posted 7 months ago #

    Hello,

    I'm using Contact Form 7 and it works fine when I'm using an external mailadres. No that I've launched the site, it must be send to an e-mailadres with the same domain as the website (example: contact form on http://www.domain.nl to info@domain.nl)

    The mails don't appear in the mailbox (also not in spam). Do I need to specify SMTP details with an extra plugin?

    My hostingcompany don't use smtp in my hosting/web space: I must set my ISP as smtp on my outlook box. What is the best way of making this work?

    http://wordpress.org/plugins/contact-form-7/

  2. ikookmaar
    Member
    Posted 7 months ago #

    This sounds like an issue within your hosting environment. I had the same problem once and solved it by filling in the "locally delivered mail domains" somewhere in the hosting administration panel....

  3. Dimitris73
    Member
    Posted 7 months ago #

    Hello,
    I have the exact same problem. The e mail is sent when I'm using an external mailaddress. But not a e-mail address with the same domain as the website (@mydomain.com).
    I am also using zoho mail for my e mails (I contacted zoho but they said it was not their issue). Could using an external email sevice (the mx records are pointing to zoho) be causing the problem, or sould I also look for a "locally delivered mail domains" field? Should I look for this on zoho or on my server that is hosting the site?
    Thank you

  4. buzztone
    Member
    Posted 7 months ago #

    @Dimitris73 - As per the Forum Welcome, please post your own topic.

    Posting in an existing topic prevents being able to track issues by topic. Added to which, your problem - despite any similarity in symptoms - is likely to be completely different.

  5. buzztone
    Member
    Posted 7 months ago #

    @kristonweb - See Setting Up Mail - there is a section at the bottom of the page that covers If You Have Email Problems. In your case see Ensure proper return address is used.

  6. kristonweb
    Member
    Posted 6 months ago #

    thanks for your reply.

    At another website I had a similar problem in the past. The solution was to force the mailserver to deliver the mail externaly instead of local delivery.

    I've contacted my hosting company and they changed the settings. They removed the domain from the local mailconfiguration, so the mail is send to my own mailserver. (hosting and domain are seperated)

    this is the solution for my problem.

  7. buzztone
    Member
    Posted 6 months ago #

    @kristonweb - If this resolves your question, it helps others contributing here, if you can flag your post as [resolved]

  8. Dimitris73
    Member
    Posted 6 months ago #

    @kristonweb
    That worked for me too.

  9. kristonweb
    Member
    Posted 6 months ago #

    @buzztone done!

Reply

You must log in to post.

About this Plugin

About this Topic