WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form 7
Mail from gmail accounts not arriving through Contact Form 7 (14 posts)

  1. Don Pyle
    Member
    Posted 1 year ago #

    Hi - I am losing my mind with this. I am using Contact Form 7 on a WordPress site. My mail server is webmail provided by ISP. I am not receiving email sent from my Contact form if the return address is a gmail address. I've been through so many forums and help guides and while there are many things i am unfamiliar with, the settings I am looking at seem pretty basic and are as correct as I can tell.

    Why would mail not come from gmail? How can I remedy this? If I send directly to mailbox, gmail arrives - only not when sent through Contact form. It is not being held in Spam folder, it's nowhere to be seen.

    Thanks

    http://wordpress.org/extend/plugins/contact-form-7/

  2. zandiver
    Member
    Posted 1 year ago #

    I am having the same problem. Emails come through to other addresses but not gmail. Does anyone know why this is and how to fix?

  3. buzztone
    Member
    Posted 1 year ago #

    Contact Form 7 uses the standard recommended method used to send emails in WordPress - wp_mail which is based on the the standard PHP mail() function.

    By default, the WordPress mailer fills in the From: field with wordpress@yourdomain.com and the From: name as WordPress. This is fine if this is a valid e-mail address which can be authenticated.

    Problems can occur if you set your real email as the From: address in CF7 and it’s something like wpgod@gmail.com. In this case the mail may not send because gmail.com is not a domain handled by the mail server at your particular WordPress install.

    A solution used by some people is to simply create a new email address called wordpress@yourdomain.com and use that in the From: address in CF7.

    See http://codex.wordpress.org/FAQ_Troubleshooting#E-mailed_passwords_are_not_being_received for a more detailed explanation of the issues involved.

  4. zandiver
    Member
    Posted 1 year ago #

    Actually, I've just discovered that the gmail one was coming through. It appears Mac Mail was hiding 'duplicates' and only displaying one. When I trawled through the individual accounts they were all there.

    The other thing I've discovered FWIW is that when you're running Contact Form 7 on your website and you have your MX records set to use a 3rd party's, such as Google, you have to disable the mail service on your domain, otherwise there will be interference. That's even though there were no mail accounts set up. Once I switched off the mail service completely, the issue was fixed.

  5. contacternst
    Member
    Posted 1 year ago #

    After quite a struggle, I finally got everything working correctly. I consolidated all my steps in a blog post. I hope it helps!

    http://www.directvermont.com/contact-form-7-dreamhost-how-to-fix/

  6. MaryKateOlsen
    Member
    Posted 1 year ago #

    @contacternst your solution worked perfectly, thank you for saving my sanity.

  7. contacternst
    Member
    Posted 1 year ago #

    Glad I could help :)

  8. ebilly
    Member
    Posted 10 months ago #

    Thanks @buzztone. Thant worked for me!

  9. pinede
    Member
    Posted 8 months ago #

    thanks the plugin Configure SMTP make it work!

  10. sepehrco
    Member
    Posted 8 months ago #

    After quite a struggle, I finally got everything working correctly. I consolidated all my steps in a blog post. I hope it helps!

    http://www.directvermont.com/contact-form-7-dreamhost-how-to-fix/

    Thank you contacternst! Your solution worked with me, too.

  11. annealex
    Member
    Posted 6 months ago #

    Hi contacternst

    your solution has not worked for me...yet.

    I set the new email address to forward to the gmail hosted email address. Was this a mistake? I want the new contact@domainname.com address to go to the gmail hosted email that my client uses, so she doesn't have to check two emails.

    Thanks for your insight!!
    Anne

  12. contacternst
    Member
    Posted 6 months ago #

    Hey Anne,

    For setting up an email account on Dreamhost, don't setup a forwarding account. Setup a Fully Hosted account. Did you do this?

  13. annealex
    Member
    Posted 6 months ago #

    No, client's email is done through google apps. HOWEVER I tried the settings with smtp.gmail.com and added in the client's username and password and it worked!! Yeah!!!!!!! Thanks!

  14. marvelycious
    Member
    Posted 3 months ago #

    Thanks so much!! It worked! Was loosing my mind on this issue! I think someone needs to add this in the FAQ or something. Took me ages to find this post, which happens to be the solution.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic