WordPress.org

Ready to get started?Download WordPress

Forums

<ul> ...<ul>...</ul>... </ul> in editor misbehaving (9 posts)

  1. ricperry1
    Member
    Posted 8 years ago #

    I am attempting to nest unordered lists. While the editor correctly displays the formatted HTML, when I save/publish the page, the nesting is completely undone and I have two or sometimes even three unordered lists (with the last unordered list incorrectly formatted).

    Manually editing the HTML does not work, because WP reformats it once it's saved/published. Anyone else experience this or come up with a solution?

    To view the defunct html, visit http://ricperry.homeip.net/news/?page_id=41

    Thanks for any help you can give.

    Rich

  2. Jonathan Landrum
    Member
    Posted 8 years ago #

    The only problem I see is the last list item (WordPress 2.0.2) isn't in a list at all. The <ul> is closed right before that <li>. Where is the nesting you talked about?

  3. Chris_K
    Member
    Posted 8 years ago #

  4. moshu
    Member
    Posted 8 years ago #

    Things you can try:
    - disable the wysiwyg
    - in Options > Writing: Formatting - uncheck the "WordPress should correct invalidly nested XHTML automatically" box

  5. ricperry1
    Member
    Posted 8 years ago #

    I know that the last item is not enclosed in the <ul> set. That is part of the problem. WP Editor reformats the HTML when I correct the code to place the </ul> tag in the correct location.

    I will turn off the option to have WP correct invalidly nested XHTML, fix the post, and thurn the option back on. I do not want it turned off because I don't know who might screw around and put bad HTML in their post.

    Thanks all for the suggestions.

  6. ricperry1
    Member
    Posted 8 years ago #

    Disabling the option "WordPress should correct invalidly nested XHTML automatically," fixing the HTML, then re-enabling "WordPress should correct invalidly nested XHTML automatically" worked.

  7. moshu
    Member
    Posted 8 years ago #

    Actually, having the wysiwyg AND the "automatic correction" turned on... causes you much more problems than you'd think. Definitely more errors than anybody could make manually :)

  8. yandel
    Member
    Posted 7 years ago #

    I'm having some problems with my text being to big. I think it has to do with the WordPress should correct invalidly nested XHTML automatically option. I turned it off, but nothing happened. The text did not display like this but after me turning this on then it happened. I'm not 100% sure it was that, but that's my guess. If you guys could check my site out here http://rihannalive.net to see if you can find the problem. Please help if you can.

  9. moshu
    Member
    Posted 7 years ago #

    "Too big" is a vague definition of the problem. Big - compared to what? What browser?

    I see everywhere the same size of text, nothing out of ordinary in FF.

Topic Closed

This topic has been closed to new replies.

About this Topic