WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] <div> and <p> tags not functionning for certain posts. (3 posts)

  1. Tilex
    Member
    Posted 7 years ago #

    I'm having problems since I changed theme on my wordpress blog. On the front page (index.php), I output the full content of the last post and then output the excerpt of the 2 following posts.

    The problem is that for some posts, for 'some' meaning it seems to be almost random, the excerpt is simply not formatted the way the .css stylesheet predicts. Like, the excerpted posts should be in a narrow column but some of them are not formatted so the whole post is on a single line that traverses the screen, and even the accents are not showing up (the UTF-8 doesn't even seem to work). As I said, this is true for some posts only, hence my interrogation.

    It is the same thing on my category.php where I output only the excerpt of all the posts under a certain category.

    Here are my style.css, category.php, and index.php files, if you want to take a look at them:

    http://blog.alexlimoges.com/wp-content/style.txt
    http://blog.alexlimoges.com/wp-content/category.txt
    http://blog.alexlimoges.com/wp-content/index.txt

    Any thought? Thanks in advance!! Alex.

  2. Tilex
    Member
    Posted 7 years ago #

    By the way, take a look at the front page here:
    http://blog.alexlimoges.com

    And at one of the category, so you'll know what I mean with my question...
    http://blog.alexlimoges.com/category/web/

  3. Tilex
    Member
    Posted 7 years ago #

    Ok, that problem is resolved now. For some reason, the browser was outputting the excerpt with <pre> tags around such that the text was not formatted.

    I forgot that I had a pluging called PHP Markdown and found out that it was the cause of the problem. I simply turned it off and everything was back to normal!

Topic Closed

This topic has been closed to new replies.

About this Topic