WordPress.org

Ready to get started?Download WordPress

Forums

<!--more--> not showing text (12 posts)

  1. ganzua
    Member
    Posted 7 years ago #

    I'm puzzled again;

    I inserted <!--more--> in a post

    Code in the index.php loop unchanged; <?php the_content(); ?>

    and instead of displaying "read more..." text it displays a dash symbol; "-"

    I thought it was a matter of my custom theme and I switched back to Kubrick. Same output.

    I tried every single combination here; http://codex.wordpress.org/Customizing_the_Read_More and nothing works, I get the same symbol.

    I can't find my mistake ┬┐any idea of what's wrong?

  2. drmike
    Member
    Posted 7 years ago #

    Which editor are you using? If you're manually entering that code there, you need to be either using the standard text editor or the Code tab of the Rich Text editor. Sounds like you may be using the Visual tab of the Rich text editor.

  3. ganzua
    Member
    Posted 7 years ago #

    Hi drmike;

    I think it has nothing to do with the editor wich is a very simple php editor, but I didn't change any code, I have this problem with a fresh installation of wp 2.2 in my computer server (latest version of Wamp).

    I thought it may anything to do with charset but it is utf-8 and I didn't write anything, no strange symbols.

    Do you have <!--more--> running ok in wp 2.2?

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Do you have a URL where we can actually see this happening?

    More works fine in 2.2.

  5. moshu
    Member
    Posted 7 years ago #

    drmike was referring to the editor used when you write the post in the WP admin panel!

  6. ganzua
    Member
    Posted 7 years ago #

    "Do you have a URL where we can actually see this happening?"

    -> Nop, I haven't url for my computer, sorry.

    If your 2.2 is running ok it must be a problem with my particular computer server, don't worry.

    Thanks again Otto.

  7. ganzua
    Member
    Posted 7 years ago #

    "drmike was referring to the editor used when you write the post in the WP admin panel!"

    --> ahhhhhh! sorry! I use the code editor.

    BTW, visual editor doesn't work anymore in my installation, perhaps I disabled but I don' remeber.

    I've found the problem!!!!!!!!!

    I reviewed the post and I realized that the <!--more--> was misspelled with an additional dash <!--more"-"-->

    Could this dash be automatically added by the code editor or am I a piece of clumsy?

  8. moshu
    Member
    Posted 7 years ago #

    Just for the sake of clarity:
    - if you are using the wysiwyg editor (rich text, visual, whatever) AND you type in the code as <!--more--> - it will NOT work
    - when using the wysiwyg you have a button for it: use that (left from the ABC/spellchecker
    - if you disable the wysiwyg, again you have a Quicktag named "more"

    It can't be simpler than this!

  9. ganzua
    Member
    Posted 7 years ago #

    Thanks for the explanation, moshu.

    Regarding the visual editor I don't know what I did but it is not working, I get what you can see in this image;

    http://www.imagehosting.com/show.php/677884_notoolbar.jpg.html

    and no tool bar

    I told you I'm a piece of clumsy!

  10. Samuel Wood (Otto)
    Tech Ninja
    Posted 7 years ago #

    Disable all your plugins and see if that corrects it. Then reenable your plugins one by one until you find the one that interferes with it.

  11. ganzua
    Member
    Posted 7 years ago #

    "Disable all your plugins and see if that corrects it. Then reenable your plugins one by one until you find the one that interferes with it."

    Hi Otto42!

    I had two plugins engaged. I deactivated both, and I recovered the tool bar. Then I reenabled both of them and the tool bar is still there.

  12. ganzua
    Member
    Posted 7 years ago #

    Yesterday I had the same problem again, toolbar disappeared. Perhaps it is a bug.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.