WordPress.org

Ready to get started?Download WordPress

Forums

JW Player for Flash & HTML5 Video
[resolved] Love your plugin, but having problems... (11 posts)

  1. chiaroscuro1
    Member
    Posted 8 months ago #

    Hi,

    After trying many video player plugins, I like yours the best because of ease of use and the "look and feel" of it, but I'm having problems with it, as summarized below.

    The JW Player plugin is currently set to Flash default. My website page link is: http://www.catalysthealthmedia.com/test/

    When set to Flash Player default:

    Safari: The player works fine, but you have to load the page twice, since the black box for the player just flashes and disappears on the first load.
    Firefox: The black box for the player flashes and never reappears, no matter what you do, so you never have access to the player.
    Android: The player doesn't ever appear at all.

    When set to HTML5 player default:

    Safari: Video player appears, but media never loads.
    Firefox: Video player never appears
    Android: Video player never appears

    These observations are true when JW Player is used to embed self-hosted or YouTube videos. The videos are encoded in MP4 h.264 format. My theme does include fitvids,which I read JWPlayer had a conflict with, but that this was fixed in the latest version which automatically disables fitvids.

    I really need this video player to work cross platform. Do you have any suggestions regarding how to fix these issues? Do you think uploading and using the previous version of JWPlayer might be a fix?

    .

    http://wordpress.org/plugins/jw-player-plugin-for-wordpress/

  2. JW Player
    Member
    Plugin Author

    Posted 8 months ago #

    I wonder what other plugins are enabled? If you disable plugins/try the default theme, do the same issues happen?

  3. chiaroscuro1
    Member
    Posted 8 months ago #

    Deactivating all the plugins except JW Player didn't help.

    In fact, for awhile the JWPlayer did the same thing in Safari that it is doing in Firefox, that is, you see the black box background for the player flash when the page loads and then it disappeared completely, leaving a white page. This happened, EXCEPT if you cleared the cache a few times, closed the Safari browser window completely and then opened it up again, then the JW Player loaded on the first try. However, for some unknown reason this new problem resolved itself and now it is back to loading a white page on the first page load and the JW Player on the second page load in Safari.

    I also discovered that the native WordPress video player seems to be the only one that works in Firefox. However, for Safari, the native player appears but won't load the media, and in Android a non-responsive native player appears but when you try to play it you get the message, "sorry can't play this video." I know you don't support problems with the native WordPress player, but thought this info might contribute to figuring out what the problem is.

  4. chiaroscuro1
    Member
    Posted 8 months ago #

    I just loaded a WordPress theme and tried your plugin and I get the very same results that I reported above. Except now, the JW Player DOES show up in Firefox rather than flashing and disappearing, but if you try to play the video you get the message "error playing media, file not found."

    So, I guess that this eliminates the theme I was originally using as the problem? Any other suggestions?

  5. JW Player
    Member
    Plugin Author

    Posted 8 months ago #

    That error means your server is not returning the MP4 MIME TYPE.

  6. chiaroscuro1
    Member
    Posted 8 months ago #

    That's interesting. The file is formatted in MP4 h.264, as I noted. And, I used a change mime type plugin to get the server to recognize MP4 files. I guess my next step is to pursue this problem with my host to see if the problem is caused by a server issue. So, I will do that, but please don't mark this topic as resolved until I report back that this was the cause of the problem, since I don't want to open another thread if it wasn't.

    Thanks for your help!

  7. JW Player
    Member
    Plugin Author

    Posted 8 months ago #

    Np!

  8. chiaroscuro1
    Member
    Posted 8 months ago #

    Hi,

    I have my host looking into this problem, so far with no success. However, I did find this troubleshooting page for the JWPlayer and it refers to needing to enter code in the header for the JWPlayer to appear on the page. However, it seems that this step does not apply to the free version of the player unless you want to use analytics.

    Is this true? Or should I have entered code in the header of my site in order for the JW Player to appear in all platforms. Currently, there is no code referring to the jwplayer in the header.

  9. JW Player
    Member
    Plugin Author

    Posted 8 months ago #

    You don't need to enter anything in the header for the WP plugin.

  10. chiaroscuro1
    Member
    Posted 8 months ago #

    I figured out that the PJW MimeCode plugin I was using apparently doesn't enter mimetypes into the htaccess file, which is needed to stream video. So, I entered them myself and that solved the problem with videos playing with some plugins and the native WordPress embedder. HOWEVER, I never did get the JW Player to show up in Firefox.

    i also figured out that Android does not support MP4 h.264 AAC coded videos, which is the industry standard. They support MP4 h.263 coded videos and basic h.264 AVC coded videos. The recommended fix for this is to download a third party video player like MX player from Google play to watch MP4 h.264 AAC coded videos on Android platforms..

    Thanks for your great support!

  11. JW Player
    Member
    Plugin Author

    Posted 8 months ago #

    Np!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.