WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Lots of Trouble moving wordpress (12 posts)

  1. ethomasmcginnis
    Member
    Posted 4 years ago #

    I tried to move my blog from one URL at a Yahoo! Small Business hosting to another and have run into many problems. The latest of which is that my blog shows up as a blank page.

    When I go to my blog wp-admin, there is a log in screen, then it says my WordPress is up-to-date, but I have to click continue and then I get the blank screen again.
    http://www.etmcreative.com/blog is the URL of the problematic new blog. The old location is still active at http://www.ethomasmcginnisdesign.com/blog

    I copied all my wp files via FTP, and I exported/imported my database in phpMyAdmin. Then I updated the config.php file to my new database...what else is there? What can I do about the blank page?
    Thank you!

  2. MichaelH
    Member
    Posted 4 years ago #

    Consider using phpMyAdmin to make sure your wp_options table has the correct values in siteurl and home.

    siteurl is your WordPress address (URL) and home is your Blog Address (URL).

    And, some other info:
    http://www.tamba2.org.uk/wordpress/site-url/

    If you can't find phpMyAdmin these notes may still be useful:
    http://codex.wordpress.org/User:MichaelH/Installation_Notes/Yahoo

    Also you could add these to your wp-config.php if you can't use phpMyAdmin:
    define('WP_SITEURL', 'http://www.etmcreative.com/blog');
    define('WP_HOME', 'http://www.etmcreative.com/blog');

    Also update your permalinks when you can login to your admin. And use the plugin to replace your old url with the new one in your database: http://wordpress.org/extend/plugins/search-and-replace/

  3. ethomasmcginnis
    Member
    Posted 4 years ago #

    Thank you for your response, those are some helpful items, I was just trying to figure out how to update my permalinks.

    In a new twist since I wrote this post, I figured out that not all the files in my wp-content folder had actually uploaded when I tried to FTP the whole blog to my new site. So now, I no longer have a blank page problem.

    I've used your codes for the config file and that has helped tremendously to make the links stay on my new site.
    I think I'm getting there, thanks!!

  4. ethomasmcginnis
    Member
    Posted 4 years ago #

    Ok, I've gone into the wp_options database in phpMyAdmin and changed the URL wherever I could find it.

    One more issue is still plaguing my blog. When I am now in the dashboard and click to see posts or add new the screen is blank in the middle, no posts show up. Similarly if I click Plug-ins, I get the full blank page. (so I couldn't use the search and replace plugin!)

    Anymore help available??
    Thank you!!

  5. MichaelH
    Member
    Posted 4 years ago #

    Clear your browser cache to see if that helps or try from another computer.

    Typically, a blank screen right after install means you didn't get a complete and intact set of WordPress files uploaded to your host. I'd consider downloading a fresh copy of WordPress from the Download tab at the top of this page, then use something like 7-Zip to extract the files. Then reupload the files to your host. Review Uploading WordPress to a remote host and make sure you are using ASCII transfer mode in your FTP client.

  6. ethomasmcginnis
    Member
    Posted 4 years ago #

    Ok, two questions before I do this fresh copy of WordPress. Will I lose any of my content?
    And the ASCII transfer mode is concerning me. I got a message saying this
    "You are currently in ASCII (text) transfer mode, but one or more of the files you are about to transfer is not in the list of known ASCII file extensions set via Transmit's preferences.

    Transferring non-ASCII files in ASCII mode will cause corruption in the transferred copy of the file. Would you like to switch back to automatic mode?"

    Should I still use ASCII mode?
    Thank you again and again!!

  7. Samuel B
    moderator
    Posted 4 years ago #

    in most ftp clients "auto" mode works well

    you shouldn't lose any info as it is all stored in the database

  8. ethomasmcginnis
    Member
    Posted 4 years ago #

    Thanks! Now I can hit transfer!

  9. ethomasmcginnis
    Member
    Posted 4 years ago #

    That the info is all stored in the database...that's what I never understood and it still boggles my mind. But I'll trust you all!
    Thanks

  10. ethomasmcginnis
    Member
    Posted 4 years ago #

    I have success!! Thank you MichaelH and Samboll!

  11. Samuel B
    moderator
    Posted 4 years ago #

    Thank MichaelH - he did the heavy lifting
    thanks for resolving this

  12. CodyRo
    Member
    Posted 3 years ago #

    Nice thank you

Topic Closed

This topic has been closed to new replies.

About this Topic