WordPress.org

Ready to get started?Download WordPress

Forums

lots of issues after 3.1.1 upgrade- namely 404 pages on save/insert/etc (24 posts)

  1. evelester
    Member
    Posted 3 years ago #

    the front end seems to be working fine. But on the backend many actions result in a 404 page (not an error page just the blogs 404 page)

    two blogs it is affecting- http://everydayeve.com and http://letterstobreathe.com

    some of the actions so far:
    inserting an image into a post - when I click on 'insert' the frame directs to a 404 page, leaving the page behind it the edit post screen

    saving a draft- immediately goes to a 404 page, and does not save the draft at all. -- it is also not saving drafts on its own, my edit post screen is just showing "Saving Draft… Last edited...." and not saving.

    publishing a post- same thing

    -----this is not theme Dependant, or plugin based, I have deactivated all plugins and went to the 20/20 theme and having same problem.

    ----- this is happening to all my blogs that I have updated to 3.1.1 - which were all working prior to the upgrade (did the deactivating/theme test on all to double check)

    help!! I can't publish or save any posts and am freaking out a little lol

  2. sixyearslater
    Member
    Posted 3 years ago #

    I'm having the same problem!
    It happened before I upgraded to 3.1.1! Whats going on??

  3. dylannickelson
    Member
    Posted 3 years ago #

    Same problem here.

    When I edit a page through the WordPress graphic user interface at

    http://domainname.com/wp-admin/post.php?post=56&action=edit

    and then click "Update", the page refreshes to

    http://domainname.com/wp-admin/post.php

    resulting in a 404 error, when it should refresh to

    http://domainname.com/wp-admin/post.php?post=56&action=edit&message=1

    This didn't happen before I auto-upgraded to 3.1.1

  4. evelester
    Member
    Posted 3 years ago #

    My hosting is with JustHost- just in case that is a common denominator...

  5. sixyearslater
    Member
    Posted 3 years ago #

    Same here. Would it be?

  6. dylannickelson
    Member
    Posted 3 years ago #

    Same here.

  7. Slompy
    Member
    Posted 3 years ago #

    I'm having this same issue... My hosting is also with JustHost.

    Hey, can any of you change your permalink settings? I get this error when trying to do that too...

  8. dylannickelson
    Member
    Posted 3 years ago #

    That pretty much indicates that JustHost is likely the source of the problem.

    Now we just need some help in identifying what the problem could be.

  9. Slompy
    Member
    Posted 3 years ago #

    More info:

    This issue happens when I try update or create pages that contain images. If the page has no images, it works fine.

  10. evelester
    Member
    Posted 3 years ago #

    same here Slompy, can save draft with no images, but not with one.... hmmmmm

  11. Slompy
    Member
    Posted 3 years ago #

    Hey guys, good news. Just spoke with JustHost! Here is the convo:

    Ana: Welcome to Live Chat support, how may I help you?
    Me: Hi there, I'm having a problem with my WordPress installation. It seems to be limited to JustHost
    Me: I keep getting 406 errors when updating posts/pages that contain images
    Me: I know you guys aren't the ones who support WordPress, but in discussion with other people, it seems that JustHost is the common denominator
    Ana: Please allow me some time to check
    Me: ok, thank you
    Ana: We are aware of the issue, there is some problem with the mod_security function.
    Ana: Our admins are working on the issue, it will be resolved as soon as possible.
    Me: great! thank you very much!
    Ana: You are welcome!!

  12. evelester
    Member
    Posted 3 years ago #

    thanks so much! I was just logging in to talk to them myself!

    thank goodness it is a host problem and not something I broke this time!

  13. Slompy
    Member
    Posted 3 years ago #

    I should have done this earlier today. I've spent hours trying to fix my site. lol

    But one 3 minute convo with their Support was all it took to get the answer. Oh well, at least I know I wasn't the one who broke it. lol

  14. dylannickelson
    Member
    Posted 3 years ago #

    I too can publish and update pages without images.

    Awesome work by you Slompy, and by JustHost.

  15. dylannickelson
    Member
    Posted 3 years ago #

    From JustHost:

    Hello,

    I have disabled mod_rewrite for your domain name. Please clear browser cache and check it.
    Everything should work fine.

    Please let us know if you need more help.
    Thank you.

    Things now work fine.

  16. sixyearslater
    Member
    Posted 3 years ago #

    Yeah! At least we now know its not our fault!
    My response from justhost was

    "Our system admins are diligently working on it to fix it at the earliest."

    So I guess, its sit and wait for me.

  17. madmaison
    Member
    Posted 3 years ago #

    Just want to say how grateful I am for this page! I'm also having this issue, and I'm also using Justhost. After making myself crazy for the last hour I'm happy to see it's a justhost problem and they're on it. Thank you fellow wordpressers!

  18. asafche
    Member
    Posted 3 years ago #

    Same here. 10 WP installations, all hosted on Justhost (damn!)

    is it gonna be a cross servers solution? or do we need to open a ticket separately, so they will know which hosters have the problem?

  19. trampli1
    Member
    Posted 3 years ago #

    I am so happy to see this--Like the rest of you, I'm using JustHost too, and couldn't insert images. I suppose I'll check with JustHost & see what needs to be done! *relieved!*

  20. madmaison
    Member
    Posted 3 years ago #

    FYI, I started a livechat with tech support last night and while the chat was in progress my problem was addressed and I was able to post again. Have other folks seen improvement even if they didn't explicitly contact justhost?

  21. evelester
    Member
    Posted 3 years ago #

    ye, as of this morning everything is working again, never conteacted justHost on my own at all - yayyy!!! Thanks again Slompy!!

  22. beattle
    Member
    Posted 3 years ago #

    Justhost must have fixed that for all accounts as the site I was trying to edit last night seems to be working fine now. Edits will save, and permalinks seem to now be working. I still have no visual editor in IE9, but that seems to work fine with Firefox. I have not tried Chrome this morning.

  23. Matthew
    Member
    Posted 3 years ago #

    Does anyone know exactly what JustHost did to resolve this?

    I have the same issue, but I am with a different host - http://wordpress.org/support/topic/saving-drafts-error-404-page-not-found?replies=1

  24. madmaison
    Member
    Posted 3 years ago #

    If you look through all the posts Slompy and dylannickelson reached out to JustHost and their response was:

    From JustHost:

    Hello,

    I have disabled mod_rewrite for your domain name. Please clear browser cache and check it.
    Everything should work fine.

    Please let us know if you need more help.
    Thank you.

    So it looks like if your host disables mod_rewrite that might be a good place to start.

Topic Closed

This topic has been closed to new replies.

About this Topic