WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Lot of unresolved posts on this IE header problem - any heroes who can solve it? (5 posts)

  1. lucid_design
    Member
    Posted 4 years ago #

    Using minimalism theme for 2 different blogs I'm developing for others. Both have the same problem in IE - the header image does not display. Displays in other browsers, but not IE. Here are the sites:

    http://www.luisakolker.com/blog

    http://www.detox.fm/radio

    Here's a snippet of the style.css code:

    '#header {
    background: #fff url('images/minimalismheader.jpg') no-repeat;
    margin: 0;
    padding: 0;
    height: 200px;
    }

    #headerimg {
    margin: 0;
    height: 200px;
    padding: 0 0 0 45px;
    }'

  2. 11worth
    Member
    Posted 4 years ago #

    Can you please post the contents of your theme's header.php?

  3. lucid_design
    Member
    Posted 4 years ago #

    I may have resolved the problem. If you have IE, would you tell me if the header image is there?

    On another note, the body text is displaying at 100% wide. Any idea where that glitch could be hiding?

    Here's the header.php. Thank you.

    '<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
    <html xmlns="http://www.w3.org/1999/xhtml" <?php language_attributes(); ?>>

    <head profile="http://gmpg.org/xfn/11">
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />

    <title>Eye of the Shaman - The Shamanic Diary of Luisa Kolker</title>

    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    <link rel="alternate" type="application/rss+xml" title="<?php printf(__('%s RSS Feed', 'minimalism'), get_bloginfo('name')); ?>" href="<?php bloginfo('rss2_url'); ?>" />
    <link rel="alternate" type="application/atom+xml" title="<?php printf(__('%s Atom Feed', 'minimalism'), get_bloginfo('name')); ?>" href="<?php bloginfo('atom_url'); ?>" />
    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />

    <?php wp_head(); ?>
    </head>
    <body>
    <div id="page">

    <div id="header">
    <div id="headerimg">
    <h1>/"><?php bloginfo('name'); ?></h1>
    <div class="description"><?php bloginfo('description'); ?></div>
    </div>
    </div>
    <hr />'

  4. 11worth
    Member
    Posted 4 years ago #

    Good job! It looks okay in my IE8, and IE8 compatability mode. Do you remember what you did to correct the problem? It would be nice to know.

    As far as the body text, that as well looks okay in IE. Can you specify where it's not correct?

  5. lucid_design
    Member
    Posted 4 years ago #

    I've got IE 6.0 on a laptop that I've been checking the site it. That's where I still see the 100% body text. Apparently in higher versions of IE, it's displaying properly. It also displays well in all of my Mac browsers.

    Anybody with earlier versions of IE seeing this body text problem?

    Concerning the fix to the missing header image problem, I changed these lines of the style.css file from this:

    '#header {
    background: #url('images/kubrickheader.jpg') no-repeat bottom center;
    margin: 0;
    padding: 0;
    height: 175px;
    }

    #headerimg {
    margin: 0;
    height: 175px;
    padding: 0 0 0 45px;

    }'

    to this:

    '#header {
    background: url('images/kubrickheader.jpg') no-repeat;
    margin: 0;
    padding: 0;
    height: 200px;
    }

    #headerimg {
    margin: 0;
    height: 200px;
    padding: 0 0 0 45px;
    }'

Topic Closed

This topic has been closed to new replies.

About this Topic