WordPress.org

Ready to get started?Download WordPress

Forums

Lost my text formatting tools (41 posts)

  1. Gogambler
    Member
    Posted 5 years ago #

    Hi guys

    I have updated my WP to 2.8 today. When I try to edit or add new posts i get the usual text editor but the existing posts is only shown with white text color on a white background in HTML, so I can only see it if I mark everything. If activate "Visual" I get the HTML formatted post shown and the text editor-bar is missing.

    How can I resolve this?

    Please see this picture for an visual explanation of the problem:

    http://www.picturepush.com/public/1840447

  2. revolutionbegins
    Member
    Posted 5 years ago #

    same problem. how to fix it?

  3. mku
    Member
    Posted 5 years ago #

    me too. I'm going back to 2.71

  4. revolutionbegins
    Member
    Posted 5 years ago #

    i backed up my files. should i just upload them all and everything would be fine or do i have to change anything in the database?

  5. Gogambler
    Member
    Posted 5 years ago #

    Hmmm, there must be some better way to do this? What happens the next time an update is released?

  6. Joe Lange
    Member
    Posted 5 years ago #

    Also having trouble with 2.8:

    In Edit Post, the toolbar (bold, add link, etc) is gone.

    Also, post text only appears after I click HTML and then click back to VISUAL - then all HTML tags appear as well.

    Anyone else having troubles with this?

    Thanks

    Joe.

    Also posted at: http://wordpress.org/support/topic/278483?replies=2

  7. Joe Lange
    Member
    Posted 5 years ago #

  8. neptunelocal
    Member
    Posted 5 years ago #

    Having the exact same problem here.

  9. djmeph
    Member
    Posted 5 years ago #

    I'm having the same problem. I can only access the HTML editor, clicking on "Visual" does nothing. I have a white page with white text so I can't see as I'm typing, can only see if I highlight the text.

    I used WordPress Automatic Upgrade 1.2.5 to perform the upgrade, and it looks like I'm not the only one. Perhaps there is a link between the two, and maybe a way we can fix whatever mistake was made in the upgrade so I don't have to re-install WordPress 2.8 and reload all of my plugins. I think for now I'll go back to 2.7.1 using the backup I made.

    Thanks for your help!

  10. TheTwistedBear
    Member
    Posted 5 years ago #

    Same thing, is there a fix?

  11. djmeph
    Member
    Posted 5 years ago #

    I am using Firefox 3.0.10 in Windows 7 Beta. Also doesn't work in Google Chrome or IE8. IE8 pulls up a debugging message when I try to create a new post. Also, I can click on the icons on the left pane, but when I hover there are no options available. For example, I can click on the Pushipin icon for posts, but I can't select "new post" as no sub-menu shows up.

  12. Gogambler
    Member
    Posted 5 years ago #

    I am using firefox for my installation just FYI.

  13. Martamars
    Member
    Posted 5 years ago #

    Same problem here!

  14. SpaceCase
    Member
    Posted 5 years ago #

    I'm another person with the same problem, running on Firefox 3.0.10. I opened IE 7, and had the same problem. Would love to know the resolution to this!

    My text is behaving the same as Joe Lange above, when click to HTML and back again. No graphics are showing, hashtags and html coding visible.

    Would love to know the solution to this!

  15. sscheper
    Member
    Posted 5 years ago #

    I'm getting the same error. Any help with how to manually install or going back to 2.7.1 would be great. Until then, my plan is to check back in a couple days when wp fixes it..

  16. jordannilsen
    Member
    Posted 5 years ago #

    [RESOLVED]
    I was having the same issues after using the "automatic upgrade" plugin to download WP 2.8. The following steps resolved issue for me:

    STEP 1: Back up!
    STEP 2: Deleted wp-admin & wp-includes folder from root directory
    STEP 3: Downloaded latest wordpress version (2.8)
    STEP 4: Uploaded wp-admin & wp-includes folders to root directory
    STEP 5: Everything works great!

  17. hrbartender
    Member
    Posted 5 years ago #

    I tried the 5-step fix with the wp-admin and wp-includes folders and it's still not fixed. Downloaded the WP-insert plugin and using the WISIWIG editor as a work around until the issue is resolved.

  18. sscheper
    Member
    Posted 5 years ago #

    Didn't work for me either..

  19. revolutionbegins
    Member
    Posted 5 years ago #

    clear your firefox cache. close firefox and open it again.
    worked for me.

  20. sscheper
    Member
    Posted 5 years ago #

    didn't work for me.. weird

  21. ronitb
    Member
    Posted 5 years ago #

    Clearing the cache and cookies, and restarting, doesn't help. I've tried it in IE, Chrome, and Firefox. I've disabled most plugins.

    This is clearly a major, major bug in Automatic's release of 2.8.

  22. SpaceCase
    Member
    Posted 5 years ago #

    For what it's worth, I'm still able to compose and post from the HTML editor (instead of the Visual Editor). But I would rather have the option to use both, of course.

  23. egunda
    Member
    Posted 5 years ago #

    Me too facing exactly the same problem on my 2 blogs [hosted on same server] What to do now. Its not the browser issue

  24. abonoda
    Member
    Posted 5 years ago #

    Same exact issue here.

  25. ronitb
    Member
    Posted 5 years ago #

    Go to tools and re-install. Fixed it for me.

  26. abonoda
    Member
    Posted 5 years ago #

    Re-installing it did nothing for me.

  27. Joe Lange
    Member
    Posted 5 years ago #

    @ronitb:

    That worked for me too. Just TOOLS, UPGRADE, and RE-INSTALL AUTOMATICALLY.

    Thanks.

  28. manansaini
    Member
    Posted 5 years ago #

    hi guys,

    I also update but everything fine here.

    actually i uses one plugin for advanced options here is link of plugin:
    http://www.laptoptips.ca/projects/tinymce-advanced/

    may be because of this i am able to see.

    here is mine view:

    http://img3.imageshack.us/img3/4588/66915632.jpg

    So i wanna suggest you those who have problems try this plugin :) This has also more option than inbuilt plugin.:)

    Regrads,
    Manan Saini
    http://www.lmtutorials.com

  29. ronitb
    Member
    Posted 5 years ago #

    abonoda: try clearing your cache and cookies and restarting your browser.

  30. neptunelocal
    Member
    Posted 5 years ago #

    This is what worked for me:

    Clear all private data from firefox (cache, cookies, etc)

    Then goto Tools > Upgrade >Re-install automatically.

    The first time I did this it didnt work, so be sure to clear browser data, and then try it.

Topic Closed

This topic has been closed to new replies.

About this Topic