WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] lost my internal links (6 posts)

  1. mychocolatemoments
    Member
    Posted 2 years ago #

    I just migrated my blog from WordPress.com today. So far, most things are working ok, except none of my internal links seem to be working. Anytime I click on a link it just takes me back to the home page (i.e. I have a recipe page on my blog with tons of recipes I've featured, when I click on the link to take me to the pumpkin bread recipe, it just takes me to the home page.

    Any ideas on how to get my links back?

    http://mychocolatemoments.com/

  2. David Choi
    Member
    Posted 2 years ago #

    Go to

    Admin Panel > Settings > General

    and see if Site Address (URL) and WordPress Address (URL) are set correctly to your new site's domain name.

  3. mychocolatemoments
    Member
    Posted 2 years ago #

    I checked, and they are correct

  4. David Choi
    Member
    Posted 2 years ago #

    Then check if those menu items are custom links or page/post links? Because if they are custom links, you have to update the whole URL address manually for each item.

    If they are page/post links, should have been updated automatically.

  5. Gaurav Raghav
    Member
    Posted 2 years ago #

    Go to your wordpress.org dashboard and in settings change your permalink structure same as you use on wordpress.com . That will help i think .

  6. mychocolatemoments
    Member
    Posted 2 years ago #

    @Gaurav - that worked! Thank you so much!

Topic Closed

This topic has been closed to new replies.

About this Topic