WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Lost Feed, Categories, and Permalinks after 2.0.4 to 2.0.5 upgrade (8 posts)

  1. RoboPower
    Member
    Posted 7 years ago #

    First of all, I want to apologize for "bumping" my previous post:

    http://wordpress.org/support/topic/97267?replies=3

    I work in Tech Support, and I didn't realize that most of the people on the WordPress forum are answering questions for free. Props to all of you! I can't wait till our forums are to that level! I'll be sure to check these forums in the future and add my own knowledge:)

    Ok, with all that said, I fixed that problem. But now, I have a much more critical problem. For some reason, after I upgraded from 2.0.4 to 2.0.5, I lost my links to my Categories, Permalinks, and worst of all, my RSS feed:(

    http://blog.trossenrobotics.com/

    Anyone have any ideas as to what could've caused this?

  2. moshu
    Member
    Posted 7 years ago #

    Did you keep your .htaccess file during the upgrade or did you delete it by accident?
    Anyway, it seems to be a simple permalink issue - I'd check and set again the permalink settings.

  3. RoboPower
    Member
    Posted 7 years ago #

    I didn't have a .htaccess file before, at least not that I remember... I backed up all of my files though before the upgrade, so if I had the .htaccess file before, it is in that folder. Where is .htaccess located? I ran a search for the string, "htaccess" in the folder that contains all my backup files and never came up with anything.

    Would not having this file generate all the "Page Not Found" errors I get?

  4. moshu
    Member
    Posted 7 years ago #

    Oops, sorry. You are on a Win (IIS) server. No .htaccess there.

    The issue is still related to your Permalinks. Your "nice" permalinks don't work.
    E.g. this gives a 404:
    http://blog.trossenrobotics.com/index.php/archives/2006/11/
    however, the default permalink structure shows the page:
    http://blog.trossenrobotics.com/index.php/?m=200611

    Did you try re-setting your permalinks as I said above?

  5. RoboPower
    Member
    Posted 7 years ago #

    I checked my Custom Structure (under Customize Permalink Structure) and it hasn't changed from what I had before the upgrade:

    /index.php/archives/%year%/%monthnum%/%day%/%postname%/

    With the Category Base being:

    /index.php/category

    Sorry for my ignorance, but what do you mean by:

    "however, the default permalink structure shows the page:
    http://blog.trossenrobotics.com/index.php/?m=200611"

    BTW, I did try to delete the "/index.php/" on both the Category and Custom Structure, and refreshed my blog page, and that didn't work, so I changed it back to the way it was:( Is this what you mean by resetting the permalink structure?

  6. moshu
    Member
    Posted 7 years ago #

    Yes, I meant to save again your options. And yes, on a win server the nice permalinks don't work without the "index.php" bit.

    And if you clicked on the link you quoted - it shows your November archives. I didn't mean anything else, just the fact that the default permalink structure works, the custom doesn't.

    Unfortunately, I don't know anything about IIS servers.

  7. RoboPower
    Member
    Posted 7 years ago #

    Thanks, I didn't think to click on the default permalink that you posted above:( I didn't know that was working.

    I checked my host's database via phpMyAdmin to see if the links are the correct GUID's and they are. All the GUID's are the links with my custom permalink structure...

    What could possibly be causing this problem? Is there some file in the new update that may have broken the connection between the links and the database or something?

  8. RoboPower
    Member
    Posted 7 years ago #

    I figured it out! I must have accidentally deleted the php.ini file in my root containing the following two lines:

    cgi.fix_pathinfo = 1
    cgi.force_redirect = 0

    FYI, for anyone who reads this, you can find this information at the following page:

    http://codex.wordpress.org/Using_Permalinks#Using_Permalinks_Without_mod_rewrite

Topic Closed

This topic has been closed to new replies.

About this Topic