WordPress.org

Ready to get started?Download WordPress

Forums

Lose a few colours in IE, but looks perfect in Firefox! help (13 posts)

  1. cashbagg
    Member
    Posted 8 years ago #

    My site is http://www.hornyoyster.com

    In IE if u click on the buttons on left, you lose colours of font and metallic background. I'm stumped.

    Works fine in FF though.

    Help please!!!

  2. cashbagg
    Member
    Posted 8 years ago #

    Can't believe I'm not gettin any answers on this. To me it would seem like a common thing. Alas, my searches on the topic have turned up nothing. :(

  3. Chris_K
    Member
    Posted 8 years ago #

    Try to wait longer than 50 minutes before bumping posts.

    Many of the volunteer support folks look for posts with no answers and you just removed yourself from that queue.

  4. LiverpoolLad
    Member
    Posted 8 years ago #

    It works fine in IE7.

    It might be the visited state in the Css, or the active.

    Or some setting you put on the background image.

  5. cashbagg
    Member
    Posted 8 years ago #

    "It might be the visited state in the Css, or the active."

    Sorry, what does that mean exactly?

    "Or some setting you put on the background image."

    As far as i know, backgrounds are average jpg's...No settings on them.

  6. Doodlebee
    Member
    Posted 8 years ago #

    You have no styling set in your CSS for the "current-cat" class in your li tags. You also have no "a:visited" styling, so it's reverting to a nothing state.

    You need to provide styling for both things for it to work.

  7. cashbagg
    Member
    Posted 8 years ago #

    I am a total newbie. I downloaded this free theme called "Spirit" just for that reason. I figured all the tricky stuff you just mentioned would have been taken care of. I'll be honest, I have no idea what u are talking about! How do I go about "providing styling for both things for it to work"

  8. cashbagg
    Member
    Posted 8 years ago #

    Would it help if I post some of my CSS?

  9. moshu
    Member
    Posted 8 years ago #

    No. I'd delete it :)
    For posting long code, please use a pastebin service, like
    http://pastebin.com
    http://pastebin.ca
    http://paste.uni.cc
    pastebin.co.uk
    and post back with the URL.

  10. cashbagg
    Member
    Posted 8 years ago #

    here's my style.css

    http://pastebin.com/754655

    If there's anything else u guys wanna see, please ask me. thx.

  11. cashbagg
    Member
    Posted 8 years ago #

    bump b4 bed.

  12. cashbagg
    Member
    Posted 8 years ago #

    Anyone?

  13. cashbagg
    Member
    Posted 8 years ago #

    OK, with a little help, got half my problem fixed. Added the following:

    .vnav a:visited {background:url(images/titanium2.jpg)}

    Now my background remains after being visited, however I still lose white font colour.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.