WordPress.org

Ready to get started?Download WordPress

Forums

Lord! Help with pagination (8 posts)

  1. writechoice
    Member
    Posted 4 years ago #

    When I click on "all article" category, the result shows 25 excerpts. But at the bottom of the page when I click on "previous articles", it says:
    "500 - Internal server error. There is a problem with the resource you are looking for, and it cannot be displayed."

    Can someone please help? And I am stupid journalist. I don't even know the C of coding. The link below will take you to the page I am referring to.

    http://www.writechoice.co.in/writechoice/?cat=3

  2. s_ha_dum
    Member
    Posted 4 years ago #

    There is something weird about your 'Previous Entries' link. With pretty permalinks it should read something like http://www.writechoice.co.in/writechoice/index.php/<categoryname>/page/2/. Without pretty permalinks it should read http://www.writechoice.co.in/writechoice/index.php/paged=2&cat=3. Instead you have what looks like a mix of both-- http://www.writechoice.co.in/writechoice/index.php/page/2/?cat=3.

    Have you tried to create a custom permalink structure? Do you have this problem with the default permalink setting-- the one that uses the ?p= syntax? You are also hosted on an IIS7 server, so the setup is different from the Apache setup I'm familiar with. Looks like you need to make sure that your web.config file is correct. I can't find one at all, actually. Maybe someone with experience running WP on IIS can help.

  3. writechoice
    Member
    Posted 4 years ago #

    Hey mate! Thanks for your reply. Yes, I was using custom custom permalink structure. Now I have made it pretty. Now, it is [http://www.writechoice.co.in/writechoice/2009/10/12/sample-post/]
    But I am still facing the problem.

    This is what I have in my web.config fie:

    -------------------------------------------------------
    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <defaultDocument>
    <files>
    <add value="index.php" />
    </files>
    </defaultDocument>
    </system.webServer>
    </configuration>
    -----------------------------------------------

    When I removed the web.config file from http://www.writechoice.co.in/writechoice, I could not see the category page: http://www.writechoice.co.in/writechoice/?cat=3

    Could you please help?

  4. s_ha_dum
    Member
    Posted 4 years ago #

    I don't really know web.config file syntax but that does not look like this. Is that what WordPress told you to put in web.config?

  5. writechoice
    Member
    Posted 4 years ago #

    I think the host put this web.config file in my website after I started experiencing some problems.

    Is it likely that by replacing the entire wordpress package I will be able to see it properly. I am asking because I upgraded the wordpress version in the past few months. I think that was a mistake.

  6. s_ha_dum
    Member
    Posted 4 years ago #

    You may need both this part and the part that WP inserts.

  7. writechoice
    Member
    Posted 4 years ago #

    Hi! When I created the ALL IN SEO PACK plugin, it started working properly. But I want an SEO plugin. Which one shall I use?

  8. writechoice
    Member
    Posted 4 years ago #

    Hi! When I removed [REMOVED] the ALL IN SEO PACK plugin, it started working properly. But I want an SEO plugin. Which one shall I use?

Topic Closed

This topic has been closed to new replies.

About this Topic